View Issue Details

IDProjectCategoryView StatusLast Update
0004382Talermerchant frontend (blog)public2016-10-11 17:28
ReporterFlorian DoldAssigned ToMarcello Stanisci 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.0 
Target Version0.1Fixed in Version0.1 
Summary0004382: merchant does not notify wallet about successful/failed payments
Descriptionsuccessful payments: The wallet needs to store the merchant's signature

failed payments: The wallet needs to verify proofs for double spending / offer export / escalation to auditor
TagsNo tags attached.

Relationships

duplicate of 0004527 closedFlorian Dold merchant needs mechanism to inform wallet about failed payments 

Activities

Florian Dold

2016-05-26 22:07

manager   ~0010773

This is actually a duplicate of something that was fixed recently.

The fix of 0004527 only addressed failed payments though, and the wallet still doesn't react very intelligently to it (no checking of double spending proofs, auditor notification).

Marcello Stanisci

2016-07-01 14:44

manager   ~0010954

This issue will be solved once a protocol for this notification will be defined.

Marcello Stanisci

2016-10-07 19:07

manager   ~0011273

In 3dceaa0f both frontends echo the signed response from the backend (0004702)

Issue History

Date Modified Username Field Change
2016-04-07 11:59 Florian Dold New Issue
2016-04-14 00:52 Christian Grothoff Product Version => 0.0
2016-04-14 00:52 Christian Grothoff Target Version => 0.1
2016-05-02 09:11 Christian Grothoff Priority normal => high
2016-05-02 09:11 Christian Grothoff Status new => confirmed
2016-05-26 21:59 Christian Grothoff Assigned To => Marcello Stanisci
2016-05-26 21:59 Christian Grothoff Status confirmed => assigned
2016-05-26 22:05 Florian Dold Relationship added duplicate of 0004527
2016-05-26 22:07 Florian Dold Note Added: 0010773
2016-07-01 14:44 Marcello Stanisci Note Added: 0010954
2016-07-01 14:45 Marcello Stanisci Priority high => normal
2016-09-27 22:28 Christian Grothoff Target Version 0.1 => 0.2
2016-10-07 19:07 Marcello Stanisci Note Added: 0011273
2016-10-07 19:07 Marcello Stanisci Status assigned => resolved
2016-10-07 19:07 Marcello Stanisci Resolution open => fixed
2016-10-07 19:23 Christian Grothoff Fixed in Version => 0.1
2016-10-07 19:23 Christian Grothoff Target Version 0.2 => 0.1
2016-10-11 17:28 Christian Grothoff Status resolved => closed