View Issue Details

IDProjectCategoryView StatusLast Update
0004118Talerdocumentationpublic2016-11-20 03:26
ReporterFlorian DoldAssigned ToMarcello Stanisci 
PrioritynormalSeveritytextReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.0 
Target Version0.2Fixed in Version0.2 
Summary0004118: document payment execution page mechanism
DescriptionThe purpose and DOM event protocol of the execution page mechanism is not explained at the moment.
TagsNo tags attached.

Activities

Marcello Stanisci

2016-03-22 19:31

manager   ~0010314

https://api.taler.net/integration-merchant.html#payment-protocol

Christian Grothoff

2016-03-22 23:09

manager   ~0010315

Documentation is still way to hard to understand, needs some more work. To be discussed together.

Marcello Stanisci

2016-07-06 12:22

manager   ~0010972

I'd remove any mention of 'offering URL' as it relates to the generation of the contract, and just focus on the mere payment via fulfillment URL..

Marcello Stanisci

2016-07-06 17:48

manager   ~0010973

simplifyed in bba5907..36c085b

Marcello Stanisci

2016-07-06 18:12

manager   ~0010974

put links for deposit permission and contract mentioning

Christian Grothoff

2016-08-30 15:20

manager   ~0011082

Updated to describe more what the new 402-based process does in 54d20ec..113f6d5. However, details (402 headers, JavaScript examples) still need to be added.

Marcello Stanisci

2016-10-12 15:03

manager   ~0011312

Passing to Florian because of some FIXMEs in integration-merchant.rst which are strictly related to the latest wallet.

Marcello Stanisci

2016-11-09 13:43

manager   ~0011459

Since there is already a page meant to describe the low-level signaling between
wallets and frontends/banks (see 0004722), we can just describe the JS way of payment protocol
in terms of how to use taler-wallet-lib. (which is basically what already happens in the texinfo tutorial).
Because of that, I can reassign this issue to me.

Marcello Stanisci

2016-11-09 15:22

manager   ~0011460

Addressed in 826dbae.

root

2016-11-15 00:41

administrator   ~0011493

Has this bug been fully resolved, or is there something left to do?

root

2016-11-15 00:45

administrator   ~0011495

Marcello says this is fully resolved.

Issue History

Date Modified Username Field Change
2015-12-29 11:48 Florian Dold New Issue
2015-12-29 11:48 Florian Dold Assigned To => Florian Dold
2015-12-29 11:48 Florian Dold Status new => assigned
2016-01-22 23:20 Christian Grothoff Severity minor => text
2016-01-22 23:20 Christian Grothoff Product Version => 0.0
2016-01-22 23:20 Christian Grothoff Target Version => 0.1
2016-03-19 19:46 Christian Grothoff Assigned To Florian Dold => Marcello Stanisci
2016-03-20 21:53 Torsten Grothoff Issue cloned: 0004252
2016-03-22 19:31 Marcello Stanisci Note Added: 0010314
2016-03-22 19:31 Marcello Stanisci Status assigned => resolved
2016-03-22 19:31 Marcello Stanisci Resolution open => fixed
2016-03-22 23:09 Christian Grothoff Note Added: 0010315
2016-03-22 23:09 Christian Grothoff Status resolved => feedback
2016-03-22 23:09 Christian Grothoff Resolution fixed => reopened
2016-07-06 12:22 Marcello Stanisci Note Added: 0010972
2016-07-06 17:48 Marcello Stanisci Note Added: 0010973
2016-07-06 18:12 Marcello Stanisci Note Added: 0010974
2016-07-08 12:03 Christian Grothoff Assigned To Marcello Stanisci => Christian Grothoff
2016-07-08 12:03 Christian Grothoff Status feedback => acknowledged
2016-07-08 12:03 Christian Grothoff Status acknowledged => feedback
2016-08-30 15:20 Christian Grothoff Note Added: 0011082
2016-08-30 15:20 Christian Grothoff Assigned To Christian Grothoff => Florian Dold
2016-08-30 15:20 Christian Grothoff Status feedback => assigned
2016-09-26 18:55 Christian Grothoff Assigned To Florian Dold => Marcello Stanisci
2016-10-11 17:21 Christian Grothoff Target Version 0.1 => 0.2
2016-10-12 15:03 Marcello Stanisci Note Added: 0011312
2016-10-12 15:03 Marcello Stanisci Assigned To Marcello Stanisci => Florian Dold
2016-11-09 13:43 Marcello Stanisci Note Added: 0011459
2016-11-09 13:44 Marcello Stanisci Assigned To Florian Dold => Marcello Stanisci
2016-11-09 15:22 Marcello Stanisci Note Added: 0011460
2016-11-15 00:40 root Target Version 0.2 => 0.3
2016-11-15 00:41 root Target Version 0.3 => 0.2
2016-11-15 00:41 root Note Added: 0011493
2016-11-15 00:45 root Status assigned => resolved
2016-11-15 00:45 root Resolution reopened => fixed
2016-11-15 00:45 root Fixed in Version => 0.2
2016-11-15 00:45 root Note Added: 0011495
2016-11-20 03:26 Christian Grothoff Status resolved => closed