View Issue Details

IDProjectCategoryView StatusLast Update
0003800Talerwallet (WebExtensions)public2017-10-23 10:48
ReporterMarcello StanisciAssigned ToFlorian Dold 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Product VersionSVN HEAD 
Target Version0.5Fixed in Version0.4 
Summary0003800: Error handling
DescriptionThe case 200 is done. We need to manage a payment not well ended, or a redirect we may get from the merchant, or a well ended payment but not acknowledged by the merchant. To be designed and implemented.
TagsNo tags attached.

Relationships

parent of 0004372 closedMarcello Stanisci error handling: blank page if payment takes too long 
parent of 0004378 closedFlorian Dold error handling: retry failed withdrawal operations 
related to 0004103 closedFlorian Dold merchant page returns redirect for /pay, but it should return JSON with a fulfillment link 

Activities

Marcello Stanisci

2015-10-13 22:35

manager   ~0009723

This bug belongs to "errors management". Should it target some further
release?

Christian Grothoff

2015-10-18 00:35

manager   ~0009739

No, error handling isn't optional for banking software ;-).

Christian Grothoff

2016-02-19 21:45

manager   ~0010162

Please file separate bugs for the various error handling cases that are not yet addressed, then we can call this one resolved.

Florian Dold

2016-04-07 17:28

manager   ~0010401

Please check if any other error handling aspect come to your mind.

If not, we should
* leave this bug open, but drop if from then milestone
* assign appropriate milestones to the child bugs

Christian Grothoff

2017-10-23 10:48

manager   ~0012508

No point in keeping this open as a meta bug just in case some sub-bug appears. If there is some error handling we are missing, open a new specific bug.

Issue History

Date Modified Username Field Change
2015-05-29 09:39 Marcello Stanisci New Issue
2015-05-29 09:39 Marcello Stanisci Status new => assigned
2015-05-29 09:39 Marcello Stanisci Assigned To => Marcello Stanisci
2015-06-21 10:53 Christian Grothoff Product Version => SVN HEAD
2015-06-21 10:53 Christian Grothoff Target Version => 0.0
2015-06-21 10:57 Christian Grothoff Relationship added child of 0003763
2015-10-13 22:35 Marcello Stanisci Note Added: 0009723
2015-10-18 00:35 Christian Grothoff Note Added: 0009739
2015-10-19 14:50 Marcello Stanisci Relationship deleted child of 0003763
2015-10-23 01:20 Christian Grothoff Severity minor => feature
2015-11-17 14:50 Christian Grothoff Priority normal => high
2016-01-22 13:32 Marcello Stanisci Assigned To Marcello Stanisci => Florian Dold
2016-01-22 13:32 Marcello Stanisci Category wallet (browser-based) => wallet (WebExtensions)
2016-01-22 13:32 Marcello Stanisci Summary manage various HTTP status codes due to POSTing coins => manage various HTTP status codes due to POSTing coins (AKA error handling)
2016-01-24 03:34 Florian Dold Relationship added related to 0004103
2016-02-19 21:45 Christian Grothoff Note Added: 0010162
2016-03-20 21:53 Torsten Grothoff Issue cloned: 0004294
2016-04-07 14:58 Florian Dold Relationship added parent of 0004372
2016-04-07 14:59 Florian Dold Relationship added parent of 0004378
2016-04-07 15:00 Florian Dold Relationship added parent of 0004379
2016-04-07 17:28 Florian Dold Note Added: 0010401
2016-04-07 17:28 Florian Dold Status assigned => feedback
2016-04-08 00:06 Christian Grothoff Priority high => normal
2016-04-08 00:06 Christian Grothoff Reproducibility have not tried => N/A
2016-04-08 00:06 Christian Grothoff Target Version 0.0 =>
2016-11-07 16:45 Marcello Stanisci Summary manage various HTTP status codes due to POSTing coins (AKA error handling) => Error handling
2017-10-23 10:48 Christian Grothoff Relationship deleted parent of 0004379
2017-10-23 10:48 Christian Grothoff Status feedback => closed
2017-10-23 10:48 Christian Grothoff Resolution open => no change required
2017-10-23 10:48 Christian Grothoff Fixed in Version => 0.4
2017-10-23 10:48 Christian Grothoff Target Version => 0.5
2017-10-23 10:48 Christian Grothoff Note Added: 0012508