View Issue Details

IDProjectCategoryView StatusLast Update
0003645GNUnetATS servicepublic2018-06-07 00:25
Reportercy1Assigned ToChristian Grothoff 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSLinuxOS Version3.something
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003645: Assertion failed at plugin_ats_proportional.c:589 despite no assertion there.
DescriptionI am finding a large amount of "Assertion failed at plugin_ats_proportional.c:589" in my logs, which is odd as line 589 of plugin_ats_proportional.c isn't an assertion statement though. It's just GNUNET_break(0); I tried cleaning and recompiling, but the assertion failure log message still appears.

Jan 31 21:34:40-276032 ats-proportional-1154 WARNING UNSPECIFIED: Counted 4 active addresses, but network says to have 8 active addresses
Jan 31 21:34:40-276045 ats-proportional-1154 WARNING Active: `V8XX' `tcp' length 12
Jan 31 21:34:40-276056 ats-proportional-1154 WARNING Active: `STRN' `tcp' length 12
Jan 31 21:34:40-276067 ats-proportional-1154 WARNING Active: `P00P' `tcp' length 12
Jan 31 21:34:40-276078 ats-proportional-1154 WARNING Active: `DSTJ' `tcp' length 12
Jan 31 21:34:45-451554 ats-1154 ERROR Assertion failed at plugin_ats_proportional.c:589.
Jan 31 21:34:45-451597 ats-proportional-1154 WARNING UNSPECIFIED: Counted 3 active addresses, but network says to have 7 active addresses
Jan 31 21:34:45-451623 ats-proportional-1154 WARNING Active: `V8XX' `tcp' length 12
Jan 31 21:34:45-451635 ats-proportional-1154 WARNING Active: `P00P' `tcp' length 12
Jan 31 21:34:45-451645 ats-proportional-1154 WARNING Active: `DSTJ' `tcp' length 12
Jan 31 21:34:45-451667 ats-1154 ERROR Assertion failed at plugin_ats_proportional.c:589.
Jan 31 21:34:45-451677 ats-proportional-1154 WARNING UNSPECIFIED: Counted 2 active addresses, but network says to have 6 active addresses
Jan 31 21:34:45-451688 ats-proportional-1154 WARNING Active: `V8XX' `tcp' length 12
Jan 31 21:34:45-451698 ats-proportional-1154 WARNING Active: `DSTJ' `tcp' length 12
Steps To Reproducejust run gnunet with log level at WARNING at least.
Additional InformationI also have the transport service dying on me, with
transport-11811 ERROR Assertion failed at gnunet-service-transport_ats.c:253

and I think that's related.
TagsNo tags attached.

Relationships

duplicate of 0003619 closedChristian Grothoff plugin_ats_proportional.c:589 assertion fails in restart tests 

Activities

cy1

2015-02-01 07:33

reporter   ~0008831

Dangit this is a dupe!

https://gnunet.org/bugs/view.php?id=3619

I can't set dupes... sorry.

Christian Grothoff

2015-02-09 00:00

manager   ~0008845

I'm quite sure this is finally fixed now. Please report if there is something failing still.

Issue History

Date Modified Username Field Change
2015-02-01 06:39 cy1 New Issue
2015-02-01 06:39 cy1 Status new => assigned
2015-02-01 06:39 cy1 Assigned To => Matthias Wachs
2015-02-01 07:33 cy1 Note Added: 0008831
2015-02-01 13:17 Christian Grothoff Relationship added duplicate of 0003619
2015-02-09 00:00 Christian Grothoff Note Added: 0008845
2015-02-09 00:00 Christian Grothoff Status assigned => resolved
2015-02-09 00:00 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-02-09 00:00 Christian Grothoff Resolution open => fixed
2015-02-09 00:00 Christian Grothoff Assigned To Matthias Wachs => Christian Grothoff
2015-02-09 00:01 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed