View Issue Details

IDProjectCategoryView StatusLast Update
0003522GNUnetbuild processpublic2018-06-07 00:25
ReporterFlorian DoldAssigned ToSree Harsha Totakura 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003522: postgresql is not detected correctly
DescriptionPostgresql used to be detected correctly, now ./configure outputs

configure: NOTICE: Database support is set to MySQL: false, SQLite: true, Postgres: true

but does not set the include path correctly, resulting in a compilation error.

In file included from postgres.c:26:0:
../../src/include/gnunet_postgres_lib.h:29:22: fatal error: libpq-fe.h: No such file or directory
 #include <libpq-fe.h>
Additional InformationIt looks like m4/ax_lib_postgresql.m4 was recently added to do the detection.

Maybe the version information is just missing in the macro call?
TagsNo tags attached.

Activities

Florian Dold

2014-08-14 11:19

developer   ~0008549

It *does* work again if you change the #include to

#include <postgresql/libpq-fe.h>

So what should be included then?

Florian Dold

2014-08-14 11:20

developer   ~0008550

Strangely, Taler just uses
 #include <libpq-fe.h>
which works fine, even though the same macro from m4/ax_lib_postgresql.m4 is used.

Sree Harsha Totakura

2014-08-19 12:45

developer   ~0008551

fixed in #34128.

Issue History

Date Modified Username Field Change
2014-08-14 11:08 Florian Dold New Issue
2014-08-14 11:09 Florian Dold Assigned To => Sree Harsha Totakura
2014-08-14 11:09 Florian Dold Status new => assigned
2014-08-14 11:19 Florian Dold Note Added: 0008549
2014-08-14 11:20 Florian Dold Note Added: 0008550
2014-08-19 12:45 Sree Harsha Totakura Note Added: 0008551
2014-08-19 12:45 Sree Harsha Totakura Status assigned => resolved
2014-08-19 12:45 Sree Harsha Totakura Fixed in Version => 0.11.0
2014-08-19 12:45 Sree Harsha Totakura Resolution open => fixed
2014-09-12 17:54 Christian Grothoff Fixed in Version 0.11.0 => 0.11.0pre66
2014-09-12 17:54 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed