View Issue Details

IDProjectCategoryView StatusLast Update
0003510GNUnetrevocation servicepublic2018-06-07 00:25
ReporterBart PolotAssigned ToChristian Grothoff 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003510: Revocation test hangs forever
DescriptionOn 3 different machines (and seems like on all buildbots) test_revocation doesn't terminate and blocks a 'make check' run.

It should have a timeout and fail if it's hit.
TagsNo tags attached.

Activities

Florian Dold

2014-08-04 02:26

developer   ~0008541

Is this related to 0003428 / do you think this is a problem with the SET service?

Bart Polot

2014-08-04 02:31

manager   ~0008542

Well, the problem is not that the tests fails (which is not good, but we can live with for now), the problem is that the test doesn't end. No matter what error is encountered, the test should definitely end at some point...

Christian Grothoff

2014-11-30 20:30

manager   ~0008634

Timeout issue is fixed in SVN 34458. Test still fails (because testbed fails to connect peers).

Issue History

Date Modified Username Field Change
2014-08-04 02:23 Bart Polot New Issue
2014-08-04 02:23 Bart Polot Status new => assigned
2014-08-04 02:23 Bart Polot Assigned To => Florian Dold
2014-08-04 02:26 Florian Dold Note Added: 0008541
2014-08-04 02:31 Bart Polot Note Added: 0008542
2014-11-30 01:52 Christian Grothoff Assigned To Florian Dold => Christian Grothoff
2014-11-30 20:30 Christian Grothoff Note Added: 0008634
2014-11-30 20:30 Christian Grothoff Status assigned => resolved
2014-11-30 20:30 Christian Grothoff Fixed in Version => 0.11.0pre66
2014-11-30 20:30 Christian Grothoff Resolution open => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed