View Issue Details

IDProjectCategoryView StatusLast Update
0003424gnunet-gtkgnunet-peerinfo-gtkpublic2018-06-07 00:25
ReporterellAssigned ToMatthias Wachs 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSXubuntu-14.04-64amdOS Version
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003424: Revision 33497: All connections to my peer 10.0.2.2 are gone.
DescriptionIn gnunet-gtk->"Information about known and connected peers".
In previous revisions info showed up about connections to
10.0.2.2. But is completely gone in R 33497.
Maybe all connections to my peer are broken with this Revision.




Steps To ReproduceRevision 33497--> ...->gnunet-gtk->aboriginal flag.
TagsNo tags attached.

Relationships

related to 0003448 closedChristian Grothoff GNUnet Core-level (transport? ats?) connectivity problems 
related to 0003401 closedMatthias Wachs GNUnet Maybe this observation helps: outside IP against internal IP 

Activities

ell

2014-06-20 13:39

reporter   ~0008457

Feedback:
In Revision 33738 the 10.0.2.2-Problem disappeared.

The addresses in gnunet-gtk read f.i.
tcp.0.10.0.2.2:xxxx

But 10.0.2.2 is my virtual gateway, the virtual host reads 10.0.2.15.
The address-chain to internet is:

working machine = 10.0.2.15->10.0.2.2->(nat):192.168.xx.2->(nat:)192.168.xx.1->speedport-router(T-COM)=srv1.nerdcamp.net=dynamic_IP

I would have expected tcp.0.10.0.2.15 show up in gnunet-gtk, but nevertheless
seems to work with 10.0.2.2.

Christian Grothoff

2014-10-05 13:16

manager   ~0008595

GNUnet will use various strategies to determine valid IP addresses for your system, so the fact that the IP of the 1st NAT shows up is by itself not a bug.

Christian Grothoff

2014-10-05 13:16

manager   ~0008596

My understanding of feedback from reporter was that this was fixed.

Issue History

Date Modified Username Field Change
2014-06-03 14:47 ell New Issue
2014-06-03 15:46 Christian Grothoff Assigned To => Matthias Wachs
2014-06-03 15:46 Christian Grothoff Status new => assigned
2014-06-08 13:23 Christian Grothoff Priority normal => urgent
2014-06-08 13:23 Christian Grothoff Severity minor => major
2014-06-08 13:23 Christian Grothoff Product Version => SVN HEAD
2014-06-08 13:23 Christian Grothoff Target Version => 0.11.0pre66
2014-06-08 13:24 Christian Grothoff Relationship added related to 0003401
2014-06-18 10:22 Christian Grothoff Relationship added related to 0003448
2014-06-20 13:39 ell Note Added: 0008457
2014-10-05 13:16 Christian Grothoff Note Added: 0008595
2014-10-05 13:16 Christian Grothoff Note Added: 0008596
2014-10-05 13:16 Christian Grothoff Status assigned => resolved
2014-10-05 13:16 Christian Grothoff Fixed in Version => 0.11.0pre66
2014-10-05 13:16 Christian Grothoff Resolution open => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed