View Issue Details

IDProjectCategoryView StatusLast Update
0003300GNUnettransport servicepublic2014-04-08 16:41
ReporterLRNAssigned ToMatthias Wachs 
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.10.1Fixed in Version0.10.1 
Summary0003300: Crash in transport blacklisting
Descriptionr32150
Additional Information
Reading symbols from d:\progs\gnunet\lib\gnunet\libexec\gnunet-service-transport.exe...done.
Continuing.

Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 10944.0x21c0]
0x761c321a in KERNELBASE!DebugBreak () from C:\Windows\syswow64\KernelBase.dll
(gdb) bt
#0  0x761c321a in KERNELBASE!DebugBreak () from C:\Windows\syswow64\KernelBase.dll
#1  0x0138746e in GNUNET_abort () at common_logging.c:287
#2  0x013c69f4 in GNUNET_SERVER_receive_done (client=0x80bebd0, success=1) at server.c:1661
#3  0x0040526b in transmit_blacklist_message (cls=0x807a438, size=40, buf=0x80866a8) at gnunet-service-transport_blacklist.c:398
#4  0x013c6880 in transmit_ready_callback_wrapper (cls=0x80bebd0, size=40, buf=0x80866a8) at server.c:1578
#5  0x01390d22 in process_notify (connection=0x80862c8) at connection.c:1172
#6  0x0139181f in transmit_ready (cls=0x80862c8, tc=0x28fbf0) at connection.c:1303
#7  0x013c0a09 in run_ready (rs=0x807f030, ws=0x8080048) at scheduler.c:595
#8  0x013c1285 in GNUNET_SCHEDULER_run (task=0x13cce78 <service_task>, task_cls=0x28fda0) at scheduler.c:817
#9  0x013cde9f in GNUNET_SERVICE_run (argc=3, argv=0x8069500, service_name=0x4255d8 <_Jv_RegisterClasses+4347352> "transport", options=GNUNET_SERVICE_OPTION_NONE, task=0x403fb7 <run>, task_cls=0x0) at service.c:1490
#10 0x00404772 in main (argc=3, argv=0x8069500) at gnunet-service-transport.c:963
(gdb) up
#1  0x0138746e in GNUNET_abort () at common_logging.c:287
287       DebugBreak ();
(gdb)
#2  0x013c69f4 in GNUNET_SERVER_receive_done (client=0x80bebd0, success=1) at server.c:1661
1661      GNUNET_assert (client->suspended > 0);
(gdb) p/x *client
$1 = {next = 0x809ccd0, prev = 0x80bed98, mst = 0x8083ee0, server = 0x8072038, connection = 0x80862c8, user_context = 0x0, restart_task = 0x0, warn_task = 0x0, warn_start = {abs_value_us = 0x4f16ea91fb620}, last_activity = {
    abs_value_us = 0x4f16ea9275f4f}, th = {callback = 0x0, callback_cls = 0x807a438, cth = 0x0}, idle_timeout = {rel_value_us = 0xffffffffffffffff}, reference_count = 0x1, suspended = 0x0, user_context_size = 0x0, in_process_client_buffer = 0x0,
  shutdown_now = 0x0, receive_pending = 0x1, persist = 0x0, is_monitor = 0x1, warn_type = 0x173}


I've got it once or twice on first testsuite run, and only once on the second run. The second run crash was during test_testbed_underlay.exe

This crash may have been prevented from happening because of the abundance of 0003299 crashes.
TagsNo tags attached.

Activities

Matthias Wachs

2014-02-04 14:58

manager   ~0008063

Fixed in 32203.

Issue History

Date Modified Username Field Change
2014-02-02 19:01 LRN New Issue
2014-02-02 19:01 LRN Status new => assigned
2014-02-02 19:01 LRN Assigned To => Matthias Wachs
2014-02-02 19:05 LRN Additional Information Updated View Revisions
2014-02-04 14:58 Matthias Wachs Note Added: 0008063
2014-02-04 14:58 Matthias Wachs Status assigned => resolved
2014-02-04 14:58 Matthias Wachs Resolution open => fixed
2014-04-08 16:40 Christian Grothoff Product Version => SVN HEAD
2014-04-08 16:40 Christian Grothoff Fixed in Version => 0.10.1
2014-04-08 16:40 Christian Grothoff Target Version => 0.10.1
2014-04-08 16:41 Christian Grothoff Status resolved => closed