View Issue Details

IDProjectCategoryView StatusLast Update
0003285GNUnetconversation servicepublic2014-04-08 16:42
ReporteryidsAssigned ToChristian Grothoff 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSDebianOS Version7
Product Version0.10.0 
Target Version0.10.1Fixed in Version0.10.1 
Summary0003285: gnunet-conversation reject call problem
DescriptionWhen you accept an incoming call in conversation, and then hang it up with /cancel, it is still in the "calls waiting" list. On the calling end the the call is properly terminated.
Steps To Reproduce- Accept an incoming call
- Hangup the call with /cancel
- The call is still in the incoming call list, you can see it with /status
TagsNo tags attached.

Activities

Sree Harsha Totakura

2014-01-29 10:09

developer   ~0008037

Sample output as given by yids:
    Phone active on line 0. Type `/help' for a list of available commands
    Incoming call from `pinky.gnu'. Please /accept #0 or /cancel 0 the call.
    /accept
    /status
    You are having a conversation with `pinky.gnu'.
    /cancel
    /status
    We are listening for incoming calls for ego `ingorgare' on line 0.
    Calls waiting:
    #0: `pinky.gnu'
     
    Phone active on line 0. Type `/help' for a list of available commands
    /call call.ingorgare.gnu
    Resolved address of `call.ingorgare.gnu'. Now ringing other party.
    Connection established to `call.ingorgare.gnu'
    Call terminated

Sree Harsha Totakura

2014-01-30 14:06

developer   ~0008038

I did some analysis on this and it looks like the phone_event_handler is not getting GNUNET_CONVERSATION_EC_PHONE_HUNG_UP event callback upon hanging up a call.

Christian Grothoff

2014-01-30 14:12

manager   ~0008039

Fixed in SVN 32114.

Christian Grothoff

2014-01-30 14:13

manager   ~0008040

Sree: that's intentional, as those event callbacks are only triggered if the other side does something, but not if our local client has triggered the hangup.

Issue History

Date Modified Username Field Change
2014-01-28 18:51 yids New Issue
2014-01-29 10:09 Sree Harsha Totakura Note Added: 0008037
2014-01-30 13:50 Christian Grothoff Assigned To => Christian Grothoff
2014-01-30 13:50 Christian Grothoff Status new => assigned
2014-01-30 13:50 Christian Grothoff Product Version => 0.10.0
2014-01-30 13:50 Christian Grothoff Target Version => 0.10.1
2014-01-30 14:06 Sree Harsha Totakura Note Added: 0008038
2014-01-30 14:12 Christian Grothoff Note Added: 0008039
2014-01-30 14:12 Christian Grothoff Status assigned => resolved
2014-01-30 14:12 Christian Grothoff Fixed in Version => 0.10.1
2014-01-30 14:12 Christian Grothoff Resolution open => fixed
2014-01-30 14:13 Christian Grothoff Note Added: 0008040
2014-04-08 16:42 Christian Grothoff Status resolved => closed