View Issue Details

IDProjectCategoryView StatusLast Update
0003258GNUnetcadet servicepublic2014-01-21 16:07
ReporterLRNAssigned ToBart Polot 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version0.10.0 
Target Version0.10.1Fixed in Version 
Summary0003258: Crash in mesh service during test_mesh_small_speed_reliable_backwards
DescriptionSubj, r31838
Steps To ReproduceRun test_mesh_small_speed_reliable_backwards
Additional Information
Reading symbols from d:\progs\gnunet\lib\gnunet\libexec\gnunet-service-mesh.exe...done.
Continuing.

Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 6716.0x1c38]
0x75a6321a in KERNELBASE!DebugBreak () from C:\Windows\syswow64\KernelBase.dll
(gdb) bt
#0  0x75a6321a in KERNELBASE!DebugBreak () from C:\Windows\syswow64\KernelBase.dll
#1  0x62b47436 in GNUNET_abort () at common_logging.c:287
#2  0x00408815 in GMT_get_cstate (t=0x0) at gnunet-service-mesh_tunnel.c:2206
#3  0x0040bea8 in connection_maintain (c=0x13b7c00, fwd=1) at gnunet-service-mesh_connection.c:917
#4  0x0040bfe1 in connection_fwd_keepalive (cls=0x13b7c00, tc=0x28fbe0) at gnunet-service-mesh_connection.c:955
#5  0x62b7f96d in run_ready (rs=0x13ac190, ws=0x13ad1a8) at scheduler.c:595
#6  0x62b801e9 in GNUNET_SCHEDULER_run (task=0x62b8bddc <service_task>, task_cls=0x28fd90) at scheduler.c:817
#7  0x62b8ce03 in GNUNET_SERVICE_run (argc=3, argv=0x1399568, service_name=0x42f581 <__FUNCTION__.104461+73> "mesh", options=GNUNET_SERVICE_OPTION_NONE, task=0x427ea8 <run>, task_cls=0x0) at service.c:1490
#8  0x0042825c in main (argc=3, argv=0x1399568) at gnunet-service-mesh.c:172
(gdb) up
#1  0x62b47436 in GNUNET_abort () at common_logging.c:287
287       DebugBreak ();
(gdb)
#2  0x00408815 in GMT_get_cstate (t=0x0) at gnunet-service-mesh_tunnel.c:2206
2206        GNUNET_assert (0);
(gdb)
#3  0x0040bea8 in connection_maintain (c=0x13b7c00, fwd=1) at gnunet-service-mesh_connection.c:917
917       if (MESH_TUNNEL3_SEARCHING == GMT_get_cstate (c->t))
(gdb) p/x *c
$1 = {t = 0x0, fwd_fc = {c = 0x13b7c00, queue_n = 0x0, queue_max = 0x3, next_pid = 0x0, last_pid_sent = 0xffffffff, last_pid_recv = 0xffffffff, last_ack_sent = 0x0, last_ack_recv = 0x0, poll_task = 0x0, poll_time = {rel_value_us = 0xf4240},
    poll_msg = 0x0, ack_msg = 0x0}, bck_fc = {c = 0x13b7c00, queue_n = 0x0, queue_max = 0x3, next_pid = 0x0, last_pid_sent = 0xffffffff, last_pid_recv = 0xffffffff, last_ack_sent = 0x0, last_ack_recv = 0x0, poll_task = 0x0, poll_time = {
      rel_value_us = 0xf4240}, poll_msg = 0x0, ack_msg = 0x0}, perf = 0x0, id = {bits = {0x5178e19c, 0x154b39e4, 0xe8c630a, 0x293b160, 0x292b3d13, 0x29eb00a8, 0xc78cfab4, 0xbd292062, 0xccf88f66, 0x6bd99bec, 0xf6b9bc3d, 0xab68869d, 0x4c7b5212,
      0xb66627db, 0xfef2c09, 0xeb767146}}, state = 0x2, path = 0x13b1740, own_pos = 0x2, fwd_maintenance_task = 0x0, bck_maintenance_task = 0x43, maintenance_q = 0x0, create_retry = 0x4, pending_messages = 0x0, destroy = 0x0}
(gdb)
TagsNo tags attached.

Relationships

duplicate of 0003277 closedBart Polot secretsharing sometimes crashes mesh service when running with valgrind 

Activities

Bart Polot

2014-01-21 16:07

manager   ~0008026

Same as 0003277, prabably already fixed.

Issue History

Date Modified Username Field Change
2014-01-08 17:16 LRN New Issue
2014-01-08 17:16 LRN Status new => assigned
2014-01-08 17:16 LRN Assigned To => Bart Polot
2014-01-18 15:55 Christian Grothoff Product Version => 0.10.0
2014-01-18 15:55 Christian Grothoff Target Version => 0.10.1
2014-01-21 16:07 Bart Polot Relationship added duplicate of 0003277
2014-01-21 16:07 Bart Polot Note Added: 0008026
2014-01-21 16:07 Bart Polot Status assigned => closed
2014-01-21 16:07 Bart Polot Resolution open => duplicate
2014-05-09 18:34 Christian Grothoff Category mesh service => cadet service