View Issue Details

IDProjectCategoryView StatusLast Update
0003239GNUnetcadet servicepublic2014-04-08 16:42
ReporterLRNAssigned ToBart Polot 
PriorityurgentSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
PlatformOSW32OS Version
Product Version0.10.0 
Target Version0.10.1Fixed in Version0.10.1 
Summary0003239: Crash in mesh service during normal operation
Descriptionr31706
Steps To ReproduceRun a GNUnet node
Additional Information
Reading symbols from D:\Progs\GNUnet\lib\gnunet\libexec\gnunet-service-mesh.exe...done.
Continuing.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 12104.0x2bd8]
0x00412c0c in GMC_is_sendable (c=0x0, fwd=-1) at gnunet-service-mesh_connection.c:2700
2700      if (GM_is_pid_bigger (fc->last_ack_recv, fc->last_pid_sent))
(gdb) bt
#0  0x00412c0c in GMC_is_sendable (c=0x0, fwd=-1) at gnunet-service-mesh_connection.c:2700
#1  0x00421a85 in queue_is_sendable (q=0x2c24520) at gnunet-service-mesh_peer.c:734
#2  0x00421ab3 in peer_get_first_message (peer=0x2c22ed8) at gnunet-service-mesh_peer.c:755
#3  0x00421d16 in queue_send (cls=0x2c22ed8, size=260, buf=0x2c378a4) at gnunet-service-mesh_peer.c:824
#4  0x695038ea in transmit_message (cls=0x14b7960, size=320, buf=0x2c37868) at core_api.c:661
#5  0x62b459db in client_notify (cls=0x2c37208, size=320, buf=0x2c37868) at client.c:1155
#6  0x62b50cea in process_notify (connection=0x2c25450) at connection.c:1172
#7  0x62b517e7 in transmit_ready (cls=0x2c25450, tc=0x28fbe0) at connection.c:1303
#8  0x62b7f7d1 in run_ready (rs=0x2c2cfd8, ws=0x2c2dff0) at scheduler.c:595
#9  0x62b8004d in GNUNET_SCHEDULER_run (task=0x62b8bd14 <service_task>, task_cls=0x28fd90) at scheduler.c:817
#10 0x62b8cd3b in GNUNET_SERVICE_run (argc=3, argv=0x2c192f8, service_name=0x42e3ad <__FUNCTION__.104373+73> "mesh", options=GNUNET_SERVICE_OPTION_NONE, task=0x42749c <run>, task_cls=0x0) at service.c:1490
#11 0x00427850 in main (argc=3, argv=0x2c192f8) at gnunet-service-mesh.c:172
(gdb) up
#1  0x00421a85 in queue_is_sendable (q=0x2c24520) at gnunet-service-mesh_peer.c:734
734       if (GMC_is_sendable (q->c, q->fwd))
(gdb) p q
$1 = (struct MeshPeerQueue *) 0x2c24520
(gdb) p/x *q
$2 = {next = 0x2c244e8, prev = 0x0, peer = 0x2c22ed8, c = 0x0, fwd = 0xffffffff, cls = 0x2c25378, type = 0x118, size = 0x88, start_waiting = {abs_value_us = 0x4ee3882918755}, callback = 0x0,
  callback_cls = 0x0}
TagsNo tags attached.

Activities

LRN

2013-12-23 20:32

developer   ~0007938

OK, this happened again, after a few minutes of running. So i'd say that it is "random" or "eventually".

Bart Polot

2013-12-23 21:29

manager   ~0007939

In the context of #1, could you please add to the report what is:

p/x *q->peer

Thanks!

LRN

2013-12-24 02:10

developer   ~0007941

Reading symbols from D:\Progs\GNUnet\lib\gnunet\libexec\gnunet-service-mesh.exe...done.
Continuing.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 11704.0x2394]
0x00412c0c in GMC_is_sendable (c=0x0, fwd=-1) at gnunet-service-mesh_connection.c:2700
2700      if (GM_is_pid_bigger (fc->last_ack_recv, fc->last_pid_sent))
(gdb) up
#1  0x00421a85 in queue_is_sendable (q=0x2bf4410) at gnunet-service-mesh_peer.c:734
734       if (GMC_is_sendable (q->c, q->fwd))
(gdb) p/x *q->peer
$1 = {id = 0xa, last_contact = {abs_value_us = 0x4ee3d661b64b8}, path_head = 0x2c051b8, path_tail = 0x2c05208, search_h = 0x0, tunnel = 0x0, connections = 0x2bfca40, core_transmit = 0x0,
  queue_head = 0x2bf4410, queue_tail = 0x2bf4410, queue_n = 0x1}

Bart Polot

2013-12-24 15:27

manager   ~0007942

Couldn't reproduce in linux, workaround in r31738 to avoid dereferencing a NULL connection.

Bart Polot

2014-01-21 18:15

manager   ~0008028

Long time, no see: I take it doesn't happen anymore.

Issue History

Date Modified Username Field Change
2013-12-23 20:22 LRN New Issue
2013-12-23 20:22 LRN Status new => assigned
2013-12-23 20:22 LRN Assigned To => Bart Polot
2013-12-23 20:32 LRN Note Added: 0007938
2013-12-23 21:29 Bart Polot Note Added: 0007939
2013-12-23 21:29 Bart Polot Status assigned => acknowledged
2013-12-23 21:29 Bart Polot Priority normal => urgent
2013-12-23 21:29 Bart Polot Severity minor => crash
2013-12-24 02:10 LRN Note Added: 0007941
2013-12-24 15:27 Bart Polot Note Added: 0007942
2013-12-24 15:46 Christian Grothoff Status acknowledged => feedback
2013-12-24 23:30 Christian Grothoff Product Version => 0.10.0
2013-12-24 23:30 Christian Grothoff Target Version => 0.10.1
2014-01-21 18:15 Bart Polot Note Added: 0008028
2014-01-21 18:15 Bart Polot Status feedback => resolved
2014-01-21 18:15 Bart Polot Fixed in Version => SVN HEAD
2014-01-21 18:15 Bart Polot Resolution open => fixed
2014-02-02 10:53 Christian Grothoff Fixed in Version SVN HEAD => 0.10.1
2014-04-08 16:42 Christian Grothoff Status resolved => closed
2014-05-09 18:34 Christian Grothoff Category mesh service => cadet service