View Issue Details

IDProjectCategoryView StatusLast Update
0002945GNUnettestbed servicepublic2018-06-07 00:25
ReporterSree Harsha TotakuraAssigned ToSree Harsha Totakura 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0002945: comparison of adaptive parallelisation algorithms
DescriptionCompare the old adaptive algorithm with the new one using the testbed profiler for experiments.
TagsNo tags attached.

Relationships

parent of 0002944 closedSree Harsha Totakura modify the adaptive parallelisation algorithm 

Activities

Sree Harsha Totakura

2014-06-04 16:40

developer   ~0008397

The algorithms have been compared; the data is available in the attached document.

Sree Harsha Totakura

2014-06-04 16:41

developer  

testbed_performance.ods (14,684 bytes)

Sree Harsha Totakura

2014-06-04 16:43

developer   ~0008398

From the results and my experience it looks like both the algorithms are performing equally with the aggressive one, although faster, is causing more failures than the conservative one thereby equalling to the speed of the conservative one.

Issue History

Date Modified Username Field Change
2013-07-15 15:03 Sree Harsha Totakura New Issue
2013-07-15 15:03 Sree Harsha Totakura Status new => assigned
2013-07-15 15:03 Sree Harsha Totakura Assigned To => Sree Harsha Totakura
2013-07-15 15:03 Sree Harsha Totakura Relationship added parent of 0002944
2013-09-07 21:28 Christian Grothoff Severity minor => feature
2013-09-22 17:43 Christian Grothoff Target Version 0.10.1 =>
2013-11-17 12:28 Christian Grothoff Priority normal => high
2013-11-17 12:28 Christian Grothoff Product Version => SVN HEAD
2013-11-17 12:28 Christian Grothoff Target Version => 0.10.1
2014-01-30 15:53 Christian Grothoff Target Version 0.10.1 =>
2014-04-11 15:06 Christian Grothoff Target Version => 0.11.0pre66
2014-06-04 15:31 Christian Grothoff Priority high => normal
2014-06-04 15:31 Christian Grothoff Target Version 0.11.0pre66 =>
2014-06-04 16:40 Sree Harsha Totakura Note Added: 0008397
2014-06-04 16:41 Sree Harsha Totakura File Added: testbed_performance.ods
2014-06-04 16:43 Sree Harsha Totakura Note Added: 0008398
2014-06-04 16:43 Sree Harsha Totakura Status assigned => resolved
2014-06-04 16:43 Sree Harsha Totakura Resolution open => fixed
2014-06-04 17:04 Christian Grothoff Fixed in Version => 0.11.0pre66
2014-06-04 17:04 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed