View Issue Details

IDProjectCategoryView StatusLast Update
0002657GNUnetWin32 portpublic2020-01-14 16:48
ReporterLRN Assigned Toschanzen  
PrioritynoneSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Fixed in Version0.11.7 
Summary0002657: Investigate the effect LSPs may have on GNUnet
DescriptionAccording to [1] and [2], when LSPs are installed, sockets can no longer be set non-inheritable (that is, SetHandleInformation() will work, but will not affect them).

GNUnet normally does not rely on implicit socket inheritance, and uses socket duplication API to explicitly pass socket information when that is needed (arm interception), but implicit inheritance, if it actually works, might break things (like, preventing GNUnet process from closing and re-binding a socket after spawning a child process, because child process inherits the socket, and it's still bound there).

[1] http://stackoverflow.com/questions/11847793/are-tcp-socket-handles-inheritable
[2] http://stackoverflow.com/questions/12058911/can-tcp-socket-handles-be-set-not-inheritable
TagsNo tags attached.

Activities

schanzen

2019-12-20 13:27

manager   ~0015203

Win32 support dropped in 0.11.7

Issue History

Date Modified Username Field Change
2012-11-20 09:01 LRN New Issue
2012-11-20 09:01 LRN Status new => assigned
2012-11-20 09:01 LRN Assigned To => LRN
2013-11-04 14:42 Christian Grothoff Severity minor => feature
2018-06-07 01:13 Christian Grothoff Assigned To LRN =>
2018-06-07 01:13 Christian Grothoff Status assigned => confirmed
2019-12-20 13:27 schanzen Assigned To => schanzen
2019-12-20 13:27 schanzen Status confirmed => resolved
2019-12-20 13:27 schanzen Resolution open => fixed
2019-12-20 13:27 schanzen Note Added: 0015203
2020-01-14 16:48 schanzen Status resolved => closed
2020-01-14 16:48 schanzen Fixed in Version => 0.11.7