View Issue Details

IDProjectCategoryView StatusLast Update
0002650gnunet-gtkgnunet-fs-gtkpublic2012-12-21 16:47
ReporterLRNAssigned ToLRN 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.9.5Fixed in Version0.9.5 
Summary0002650: Crash when exiting gnunet-fs-gtk
Descriptionsubj
Steps To ReproduceSearch for "image/jpeg" or "jpg".
File-sharing->Quit
Crash!
Additional Information
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 9296.0x12fc]
0x69c42306 in GNUNET_GTK_main_loop_get_object (ml=0x0, name=0x41dcf0 "GNUNET_GTK_main_window_preview_image") at ../../../gnunet-gtk-git-svn/src/lib/eventloop.c:243
243       return gtk_builder_get_object (ml->builder, name);
(gdb) bt
#0  0x69c42306 in GNUNET_GTK_main_loop_get_object (ml=warning: (Internal error: pc 0x0 in read in psymtab, but not in symtab.)

0x0, name=0x41dcf0 "GNUNET_GTK_main_window_preview_image") at ../../../gnunet-gtk-git-svn/src/lib/eventloop.c:243
#1  0x004013f3 in GNUNET_FS_GTK_get_main_window_object (name=0x41dcf0 "GNUNET_GTK_main_window_preview_image") at ../../../gnunet-gtk-git-svn/src/fs/gnunet-fs-gtk.c:111
#2  0x00404cdb in clear_metadata_display () at ../../../gnunet-gtk-git-svn/src/fs/gnunet-fs-gtk_event-handler.c:330
#3  0x00406599 in close_search_tab (tab=0x35bf880) at ../../../gnunet-gtk-git-svn/src/fs/gnunet-fs-gtk_event-handler.c:1158
#4  0x0040c3e0 in GNUNET_GTK_fs_event_handler (cls=warning: (Internal error: pc 0x0 in read in psymtab, but not in symtab.)

0x0, info=0x28fb28) at ../../../gnunet-gtk-git-svn/src/fs/gnunet-fs-gtk_event-handler.c:3524
#5  0x004d24b9 in GNUNET_FS_search_make_status_ (pi=0x28fb28, sc=0x237a4f8) at fs_search.c:60
#6  0x004d61c5 in GNUNET_FS_search_signal_suspend_ (cls=0x237a4f8) at fs_search.c:1384
#7  0x004bc46d in GNUNET_FS_stop (h=0x23a2a90) at fs_api.c:3026
#8  0x00401636 in shutdown_task (cls=warning: (Internal error: pc 0x0 in read in psymtab, but not in symtab.)

0x0, tc=0x28fc30) at ../../../gnunet-gtk-git-svn/src/fs/gnunet-fs-gtk.c:212
#9  0x62b7fa65 in run_ready (rs=0x5d9fe8, ws=0x5db000) at scheduler.c:597
#10 0x62b80203 in GNUNET_SCHEDULER_run (task=0x62b793a0 <program_main>, task_cls=0x28fdbc) at scheduler.c:785
#11 0x62b79cb9 in GNUNET_PROGRAM_run2 (argc=1, argv=0x233b5b0, binaryName=0x41d3d4 <__register_frame_info+4314068> "gnunet-fs-gtk", binaryHelp=0x41d430 <__register_frame_info+4314160> "GTK GUI for GNUnet", options=0x41c000,
    task=0x69c43583 <run_main_loop>, task_cls=0x28fe88, run_without_scheduler=0) at program.c:270
#12 0x62b79dbd in GNUNET_PROGRAM_run (argc=1, argv=0x233b5b0, binaryName=0x41d3d4 <__register_frame_info+4314068> "gnunet-fs-gtk", binaryHelp=0x41d430 <__register_frame_info+4314160> "GTK GUI for GNUnet", options=0x41c000,
    task=0x69c43583 <run_main_loop>, task_cls=0x28fe88) at program.c:305
#13 0x69c43a1d in GNUNET_GTK_main_loop_start (binary_name=0x41d3d4 <__register_frame_info+4314068> "gnunet-fs-gtk", binary_help=0x41d430 <__register_frame_info+4314160> "GTK GUI for GNUnet", argc=1, argv=0x233b5b0, options=0x41c000,
    main_window_file=0x41d410 <__register_frame_info+4314128> "gnunet_fs_gtk_main_window.glade", main_task=0x401788 <run>) at ../../../gnunet-gtk-git-svn/src/lib/eventloop.c:912
#14 0x00401e0d in main (argc=1, argv=0x233b5b0) at ../../../gnunet-gtk-git-svn/src/fs/gnunet-fs-gtk.c:545
TagsNo tags attached.

Activities

LRN

2012-11-12 08:14

developer   ~0006569

Note that this might be caused by my (yet uncommitted) changes to gnunet-fs-gtk, please confirm that this applies to SVN HEAD.

LRN

2012-11-12 16:59

developer   ~0006571

Fixed in r24916.

Note that the real culprit is, most likely, 'ml' being freed too soon. It is likely that this will cause other problems in other places, as my fix does not change anything about 'ml', but uses different way of getting widget references.

Issue History

Date Modified Username Field Change
2012-11-12 08:12 LRN New Issue
2012-11-12 08:14 LRN Note Added: 0006569
2012-11-12 16:59 LRN Note Added: 0006571
2012-11-12 17:00 LRN Status new => resolved
2012-11-12 17:00 LRN Resolution open => fixed
2012-11-12 17:00 LRN Assigned To => LRN
2012-11-14 15:09 Christian Grothoff Product Version => SVN HEAD
2012-11-14 15:09 Christian Grothoff Fixed in Version => 0.9.5
2012-11-14 15:09 Christian Grothoff Target Version => 0.9.5
2012-12-21 16:47 Christian Grothoff Status resolved => closed