View Issue Details

IDProjectCategoryView StatusLast Update
0002624libextractorpluginspublic2017-10-12 14:10
ReporterLRNAssigned Tobratao 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Versioncurrent SVN 
Target Version1.4Fixed in Version1.4 
Summary0002624: Use different codec for thumbnails
DescriptionAccording to Bratao, right now thumbnails are png-encoded. Instead lossy codecs could be used to greatly reduce thumbnails size (and/or increase their resolution?). WebP was mentioned in the discussion.
TagsNo tags attached.

Activities

Christian Grothoff

2013-01-31 19:26

manager   ~0006820

The issue is that we need to pick a format that is also easily rendered by all/most Gtk (and possibly Qt, and possibly WWW-browser) clients. We're following the standards for thumbnails (which do say png, 128x128 or similar), so I'm not sure there is a need to change this.

bratao

2013-12-23 22:32

developer   ~0007940

Changed to JPEG. Up to 90% improvement, but we should enable switching between JPG/PNG in run-time.

Issue History

Date Modified Username Field Change
2012-11-06 20:32 LRN New Issue
2013-01-31 19:26 Christian Grothoff Note Added: 0006820
2013-12-23 22:32 bratao Note Added: 0007940
2013-12-23 22:32 bratao Status new => resolved
2013-12-23 22:32 bratao Fixed in Version => 1.4
2013-12-23 22:32 bratao Resolution open => fixed
2013-12-23 22:32 bratao Assigned To => bratao
2014-01-01 22:01 Christian Grothoff Product Version => current SVN
2014-01-01 22:01 Christian Grothoff Target Version => 1.4
2017-10-12 14:10 Christian Grothoff Status resolved => closed