View Issue Details

IDProjectCategoryView StatusLast Update
0008870Talerwallet-corepublic2024-06-17 13:05
Reportersebasjm Assigned ToFlorian Dold  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.12 
Target Version0.12 
Summary0008870: exchange entry don't get updated after reaching "unavailable-update" state [2h]
Descriptioni'm trying to withdraw from the wallet, the exchange is running but wallet-core reports `exchange unavailable`

operationRetries is empty

nextUpdateStamp is in 4 hours

2024-05-27T13:40:19.002Z exchanges.ts INFO waiting for ready exchange http://exchange.taler.test:1180/
logging.js:165 2024-05-27T13:40:19.002Z exchanges.ts INFO exchange update for http://exchange.taler.test:1180/ not necessary, scheduled for 2024-05-27T13:41:51.106Z
logging.js:165 2024-05-27T13:40:19.002Z exchanges.ts INFO exchange refresh check for http://exchange.taler.test:1180/ not necessary, scheduled for 2024-05-28T13:39:51.109Z
logging.js:165 2024-05-27T13:40:19.002Z wallet.ts INFO finished wallet core request getWithdrawalDetailsForAmount with error: {
  "code": 7032,
  "when": {
    "t_ms": 1716817219002
  },
  "hint": "Error (WALLET_EXCHANGE_UNAVAILABLE)",
  "exchangeBaseUrl": "http://exchange.taler.test:1180/"
}

----------------------------------------------

sounds like it should sched an immediate update on error.
TagsNo tags attached.

Activities

Florian Dold

2024-05-27 20:16

manager   ~0022477

The exchange entry somehow got into the state UnavailableUpdate (e.g. because the master pub or currency changed), and due to the separate updateRetryCounter (which also sets the nextUpdateStamp), the broken exchange doesn't get updated.

* We should store the issue that's caused the "unavailable" state somewhere (it is *not* a task error, as the task effectively succeeded, the exchange is just broken)
* Force-updating the exchange entry must also reset the nextUpdateStamp and updateRetryCounter when in the UnavailableUpdate state
* This needs a test

Florian Dold

2024-06-17 13:05

manager   ~0022639

commit 05535fdc226f39666ed0a692871f54dea904af7b (HEAD -> master, origin/master, origin/HEAD)
Author: Florian Dold <florian@dold.me>
Date: Mon Jun 17 13:05:16 2024 +0200

    wallet-core,harness: new test, provide reason for exchange entry update conflicts

Issue History

Date Modified Username Field Change
2024-05-27 15:46 sebasjm New Issue
2024-05-27 15:46 sebasjm Status new => assigned
2024-05-27 15:46 sebasjm Assigned To => Florian Dold
2024-05-27 20:16 Florian Dold Note Added: 0022477
2024-05-27 20:22 Florian Dold Summary exchange don't get updated => exchange entry don't get updated after reaching "unavailable-update" state
2024-06-16 17:48 Florian Dold Summary exchange entry don't get updated after reaching "unavailable-update" state => exchange entry don't get updated after reaching "unavailable-update" state [2h]
2024-06-17 13:05 Florian Dold Status assigned => resolved
2024-06-17 13:05 Florian Dold Resolution open => fixed
2024-06-17 13:05 Florian Dold Note Added: 0022639