View Issue Details

IDProjectCategoryView StatusLast Update
0008489Talerwallet (WebExtension)public2024-04-15 21:33
Reportersebasjm Assigned Tosebasjm  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Target Version0.10Fixed in Version0.10 
Summary0008489: Browser HttpRequestLib improvements
Descriptionneed to consider

* cancel token
* observability
* timeouts
TagsNo tags attached.

Relationships

related to 0008581 assignedsebasjm show observability events in WebExtension UI in dev mode 
has duplicate 0008416 closedsebasjm HTTP client libs used by WebExtension don't support cancellation tokens 

Activities

Florian Dold

2024-03-01 00:16

manager   ~0021590

Assigning to Sebastian, since these improvements are only missing for the web / service worker platform.

sebasjm

2024-03-08 19:37

developer   ~0021813

moving http obs from wallet-core to taler-util

cancel token and timeout already handled

i will make some more testing before closing

sebasjm

2024-03-12 12:11

developer   ~0021856

0b8b9950d

Issue History

Date Modified Username Field Change
2024-02-22 15:16 sebasjm New Issue
2024-02-22 15:16 sebasjm Status new => assigned
2024-02-22 15:16 sebasjm Assigned To => Florian Dold
2024-02-26 19:42 Florian Dold Target Version => 0.10
2024-03-01 00:16 Florian Dold Assigned To Florian Dold => sebasjm
2024-03-01 00:16 Florian Dold Note Added: 0021590
2024-03-01 00:17 Florian Dold Category wallet-core => wallet (WebExtension)
2024-03-01 00:17 Florian Dold Summary taler util http client improvement => Browser HttpRequestLib improvements
2024-03-05 23:24 Christian Grothoff Relationship added has duplicate 0008416
2024-03-05 23:25 Christian Grothoff Relationship added related to 0008581
2024-03-08 19:37 sebasjm Status assigned => confirmed
2024-03-08 19:37 sebasjm Note Added: 0021813
2024-03-12 12:11 sebasjm Status confirmed => resolved
2024-03-12 12:11 sebasjm Resolution open => fixed
2024-03-12 12:11 sebasjm Note Added: 0021856
2024-03-12 13:44 Christian Grothoff Fixed in Version => 0.10
2024-04-15 21:33 Christian Grothoff Status resolved => closed