View Issue Details

IDProjectCategoryView StatusLast Update
0008431Talerwallet (WebExtension)public2024-03-07 20:51
ReporterFlorian Dold Assigned Tosebasjm  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Target Version0.9.4Fixed in Version0.9.4 
Summary0008431: bank-integrated withdrawal flow: unable to cancel withdrawal when wallet automatically opens
DescriptionWhen the wallet automatically opens, once I have started a withdrawal from the bank SPA, there is currently no way to cancel it without first accepting the withdrawal in the wallet and then cancelling it at the 2FA step.
TagsNo tags attached.

Relationships

related to 0008099 assignedFlorian Dold extend transaction Withdrawal to incorporate states before accepting the operation [10h] 

Activities

sebasjm

2024-02-19 15:05

developer   ~0021373

no way to cancel the withdrawal operation since we don't have a tx yet

sebasjm

2024-02-19 15:06

developer   ~0021374

we can add a operation "cancel b-i-withdrawal by talerURI" to instruct wallet core a cancelation and then wallets should redirect to "confirm_url" after wallet core confirm that the cancellation succeded

sebasjm

2024-02-21 21:01

developer   ~0021422

now the text changed from
"Complete or cancel the operation in this page"
to
"Complete the operation in this page"

and the notification has a X where can be dismissed
image.png (7,648 bytes)   
image.png (7,648 bytes)   

Issue History

Date Modified Username Field Change
2024-02-19 01:57 Florian Dold New Issue
2024-02-19 01:57 Florian Dold Status new => assigned
2024-02-19 01:57 Florian Dold Assigned To => Florian Dold
2024-02-19 03:13 Florian Dold Assigned To Florian Dold =>
2024-02-19 03:13 Florian Dold Assigned To => sebasjm
2024-02-19 15:05 sebasjm Note Added: 0021373
2024-02-19 15:06 sebasjm Note Added: 0021374
2024-02-19 15:09 sebasjm Relationship added related to 0008099
2024-02-19 18:26 sebasjm Target Version 0.9.4 => 0.11
2024-02-21 21:01 sebasjm Note Added: 0021422
2024-02-21 21:01 sebasjm File Added: image.png
2024-02-21 21:01 sebasjm Status assigned => resolved
2024-02-21 21:01 sebasjm Resolution open => fixed
2024-02-28 19:11 Florian Dold Target Version 0.11 => 0.9.4
2024-03-07 20:50 Christian Grothoff Fixed in Version => 0.9.4
2024-03-07 20:51 Christian Grothoff Status resolved => closed