View Issue Details

IDProjectCategoryView StatusLast Update
0008362Talerlibeufin-bankpublic2024-02-13 20:30
ReporterChristian Grothoff Assigned ToAntoine A  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.9.4 
Summary0008362: when withdrawing (integrated withdrawal), the wallet no longer auto-redirects to the bank
DescriptionI now have to manually click the link, instead of automatically being back at the bank to confirm the transfer. This is a regression, used to work!
TagsNo tags attached.

Relationships

child of 0008273 assignedChristian Grothoff package and upload libeufin 0.9.4 to ftp and stable Debian/Ubuntu server 

Activities

sebasjm

2024-02-12 17:00

developer   ~0021254

Wallet core is not returning confirmTransferUrl which comes from libeufin.

This is a request I see when doing withdrawal, it does not contain confirm url. But others request to libeufin (before doing a confirmation from wallet) do show the expected field.

curl 'https://bank.taler.ar/taler-integration/withdrawal-operation/86647d6a-069d-4bec-96fc-40dd59945491' | jq .

{
  "status": "confirmed",
  "amount": "LOCAL:10",
  "sender_wire": "payto://iban/DE9813700771741",
  "suggested_exchange": "https://exchange.taler.ar/",
  "selected_reserve_pub": "RV262ADY9B1E8P78P3XSRBRWKBAJCCW03TDP8JRMZXA5CV5B88S0",
  "selected_exchange_account": "payto://iban/DE9714548806481",
  "wire_types": [
    "iban"
  ],
  "aborted": false,
  "selection_done": true,
  "transfer_done": true
}

sebasjm

2024-02-12 17:00

developer   ~0021255

could this be something related to libeufin? maybe is wallet core, if you don't see anything wrong in libeufin I will inspect wallet-core

Florian Dold

2024-02-12 22:12

manager   ~0021261

The problem seems to be that wallet-core expects confirm_transfer_url to be present initially when the withdrawal operation is in state "pending". However, libeufin now only returns it when in state "selected".

I think the exact behavior here is undocumented, so we should document the right behavior here and then either fix libeufin or wallet-core.

fdold-work@sapota ~> curl https://bank.test.taler.net/taler-integration/withdrawal-operation/7e3fa223-c89f-4f5b-a925-a495cb4410e3 | jq .
{
  "status": "pending",
  "amount": "TESTKUDOS:25",
  "sender_wire": "payto://iban/DE7012796779290",
  "suggested_exchange": "https://exchange.test.taler.net/",
  "wire_types": [
    "iban"
  ],
  "aborted": false,
  "selection_done": false,
  "transfer_done": false
}

Florian Dold

2024-02-12 22:17

manager   ~0021262

@Antoine: Can you please restore the old behavior in libeufin?

While the exact behavior wasn't documented, it was still a breaking change.

Antoine A

2024-02-13 00:01

developer   ~0021263

We always supplied the confirm_transfer_url in the GET request and only when the operation was in the "selected" state in the POST request. I made it too restrictive by only returning it when in "selected" state. I've now changed the behaviour so that it's returned when the operation is either in "pending" or "selected" state but not if it's "aborted" or "confirmed". What is the expected behaviour?

Antoine A

2024-02-13 00:05

developer   ~0021264

Fixed in 7f84324c0712097513becd7c4675e50d4194833a

sebasjm

2024-02-13 19:55

developer   ~0021277

this still happening in 5837035a, two commits after

sebasjm

2024-02-13 20:28

developer   ~0021278

wrong report, seems that I have installed latest bank but running an old one, after restarting "confirm_url" is present when wop is pending

Issue History

Date Modified Username Field Change
2024-02-10 00:02 Christian Grothoff New Issue
2024-02-10 00:02 Christian Grothoff Status new => assigned
2024-02-10 00:02 Christian Grothoff Assigned To => sebasjm
2024-02-10 00:06 Christian Grothoff Relationship added child of 0008121
2024-02-12 17:00 sebasjm Note Added: 0021254
2024-02-12 17:00 sebasjm Assigned To sebasjm => Antoine A
2024-02-12 17:00 sebasjm Status assigned => acknowledged
2024-02-12 17:00 sebasjm Note Added: 0021255
2024-02-12 22:03 Florian Dold Assigned To Antoine A => Florian Dold
2024-02-12 22:12 Florian Dold Note Added: 0021261
2024-02-12 22:12 Florian Dold Assigned To Florian Dold => Antoine A
2024-02-12 22:17 Florian Dold Note Added: 0021262
2024-02-12 22:17 Florian Dold Status acknowledged => assigned
2024-02-13 00:01 Antoine A Note Added: 0021263
2024-02-13 00:05 Antoine A Note Added: 0021264
2024-02-13 16:56 Christian Grothoff Category wallet (WebExtension) => libeufin-bank
2024-02-13 16:57 Christian Grothoff Relationship added child of 0008273
2024-02-13 16:57 Christian Grothoff Relationship deleted child of 0008121
2024-02-13 19:55 sebasjm Note Added: 0021277
2024-02-13 20:28 sebasjm Note Added: 0021278
2024-02-13 20:30 sebasjm Status assigned => resolved
2024-02-13 20:30 sebasjm Resolution open => fixed