View Issue Details

IDProjectCategoryView StatusLast Update
0008314Talerwallet-corepublic2024-04-12 01:37
Reportersebasjm Assigned Tosebasjm  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Versiongit (master) 
Target Version0.10Fixed in Version0.10 
Summary0008314: problem with current node and sqlite library
Description$ node --version
v21.6.0

$ taler-wallet-cli --wallet-db=asd balance
Error: The module '/taler-wallet-cli/build/better_sqlite3.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 115. This version of Node.js requires
NODE_MODULE_VERSION 120. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).

workaround, use the json format:
$ taler-wallet-cli --wallet-db=asd.json balance

TagsNo tags attached.

Activities

sebasjm

2024-02-04 20:14

developer   ~0021141

3028ce1b3 update the version to the latest sqlite and works with node v21.6.0

maybe we should link to the user library verison? is that possible?

Florian Dold

2024-02-16 00:38

manager   ~0021314

Not sure what you mean by that! When the nodejs version on someone's system changes, the module needs to be re-compiled.

Issue History

Date Modified Username Field Change
2024-02-04 20:12 sebasjm New Issue
2024-02-04 20:12 sebasjm Status new => assigned
2024-02-04 20:12 sebasjm Assigned To => sebasjm
2024-02-04 20:14 sebasjm Note Added: 0021141
2024-02-04 20:14 sebasjm Assigned To sebasjm => Florian Dold
2024-02-04 20:14 sebasjm Status assigned => feedback
2024-02-13 17:28 Florian Dold Target Version git (master) => 0.10
2024-02-16 00:38 Florian Dold Note Added: 0021314
2024-02-16 00:38 Florian Dold Assigned To Florian Dold => sebasjm
2024-04-03 18:51 Florian Dold Target Version 0.10 => 0.11
2024-04-11 23:21 sebasjm Status feedback => resolved
2024-04-11 23:21 sebasjm Resolution open => unable to reproduce
2024-04-12 01:37 Christian Grothoff Fixed in Version => 0.10
2024-04-12 01:37 Christian Grothoff Target Version 0.11 => 0.10