View Issue Details

IDProjectCategoryView StatusLast Update
0008092Talerwallet-corepublic2024-02-10 23:31
ReporterMarcS Assigned ToFlorian Dold  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version0.9.4 
Target Version0.9.4Fixed in Version0.9.4 
Summary0008092: DEMO: scopeInfo for KUDOS is not consistent
Descriptionresponse for operation getExchangeEntryByUrl:
"currency": "KUDOS", "scopeInfo": ["url": "https://exchange.demo.taler.net/", "type": "exchange", "currency": "KUDOS"], "exchangeEntryStatus": "preset", "exchangeUpdateStatus": "ready", "tosStatus": "proposed", "paytoUris": ["payto://iban/DE159593?receiver-name=Sandcastle+Echange+Inc"], "exchangeBaseUrl": "https://exchange.demo.taler.net/", "ageRestrictionOptions": []

vs

response for operation getBalances:
"balances": [["scopeInfo": ["currency": "KUDOS", "type": "global"], "hasPendingTransactions": false, "pendingOutgoing": "KUDOS:0", "available": "KUDOS:5", "requiresUserInput": false, "pendingIncoming": "KUDOS:0", "flags": []]
TagsNo tags attached.

Relationships

duplicate of 0008120 resolvedFlorian Dold spec and implement regional currency management APIs in wallet-core 

Activities

Florian Dold

2024-01-19 00:41

manager   ~0020918

Instead of fixing the mocking, we will directly implement the proper regional currency management APIs (0008120)

Issue History

Date Modified Username Field Change
2024-01-16 12:00 MarcS New Issue
2024-01-16 12:00 MarcS Status new => assigned
2024-01-16 12:00 MarcS Assigned To => Florian Dold
2024-01-16 12:01 MarcS Summary DEMO scope is not consistent => DEMO: scopeInfo for KUDOS is not consistent
2024-01-19 00:41 Florian Dold Status assigned => resolved
2024-01-19 00:41 Florian Dold Resolution open => won't fix
2024-01-19 00:41 Florian Dold Note Added: 0020918
2024-01-19 00:41 Florian Dold Relationship added duplicate of 0008120
2024-02-10 23:31 Christian Grothoff Fixed in Version => 0.9.4