View Issue Details

IDProjectCategoryView StatusLast Update
0007939TalerMerchant frontends (Python3)public2024-01-12 14:08
Reporterdavidak Assigned Tojavier.sepulveda  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.9.4Fixed in Version0.9.4 
Summary0007939: refund of article fails
DescriptionError encountered
Item not refundable (anymore)

Backend response:

{'wire_reports': [], 'exchange_code': 0, 'exchange_http_status': 0, 'exchange_ec': 0, 'exchange_hc': 0, 'deposit_total': 'KUDOS:0', 'contract_terms': {'amount': 'KUDOS:0.5', 'extra': {'article_name': 'The_Problems_with_older_versions_of_the_Apple_Public_Source_License_-APSL-'}, 'fulfillment_url': 'https://shop.demo.taler.net/en/essay/The_Problems_with_older_versions_of_the_Apple_Public_Source_License_-APSL-', 'public_reorder_url': 'https://shop.demo.taler.net/en/essay/The_Problems_with_older_versions_of_the_Apple_Public_Source_License_-APSL-', 'summary': 'Essay: The Problems with older versions of the Apple Public Source License (APSL)', 'wire_transfer_deadline': {'t_s': 1694717108}, 'products': [], 'h_wire': 'TNZNZM4NSTGEJWPSMV8D00R8S5B6TMBKKHAWP956RTQB0KA3TAP99CWB5JGMVJJNPDK7T812VWPFHR2P3DWCZMPZQDDQSSG3MHWEQH8', 'wire_method': 'iban', 'order_id': '2023.257-0147QNSQMAYYP', 'timestamp': {'t_s': 1694716658}, 'refund_deadline': {'t_s': 1694716778}, 'pay_deadline': {'t_s': 1694720258}, 'max_wire_fee': 'KUDOS:1', 'max_fee': 'KUDOS:1', 'wire_fee_amortization': 1, 'merchant_base_url': 'https://backend.demo.taler.net/instances/blog/', 'merchant': {'name': 'GNU Taler', 'address': {}, 'jurisdiction': {}}, 'merchant_pub': 'F59GRTB78ZAX0AS77WMQWFSDKT0Z4ST5GVA86ZN9JS8DY39PXKXG', 'exchanges': [{'url': 'https://exchange.demo.taler.net/', 'priority': 1024, 'master_pub': '1SQ43RNRCB80YH58YYEH8KQKXMZNEMPA2J2CZSQN4XSWJZ40675G'}], 'nonce': 'AKH4ECWVVRNXQ9RKA1JCNQZQPHEJ8VB7RQ5ND96QN6MAN19694WG'}, 'order_status': 'paid', 'refunded': False, 'wired': False, 'refund_pending': False, 'refund_amount': 'KUDOS:0', 'wire_details': [], 'refund_details': [], 'order_status_url': 'https://backend.demo.taler.net/instances/blog/orders/2023.257-0147QNSQMAYYP?session_id=f2fa84b8-71af-4988-ad5a-02f8e1aaa040&h_contract=R0NF5B8W89383106KXRNZ2MMGC4636MD1KCSJYZ3WZGR06T3WQ083ZK1HHTMC0V7FC3WQTY9E9P93H4YGV6F9KX209AVQWFWCTD6DCG'}
Steps To Reproduce1. buy essay in demo store
2. click refund
3. the refund fails

when i open the article again, it says:

Taler allows merchants to offer refunds to customers. This article can't be refunded anymore.

---

i tried it again with another article:

same steps. but the error looks different (see second screenshot)

Digital cash refund
Could not load the status of the term of service

Wallet operation "startRefundQueryForUri" failed
  
less info
{
  "context": [],
  "cause": {
    "details": {
      "code": 7001,
      "when": {
        "t_ms": 1694718914655
      },
      "hint": "unexpected exception (message: no purchase found, can't refund)",
      "stack": "Error: no purchase found, can't refund\n at chrome-extension://millncjiddlpgdmkklmhfadpacifaonc/dist/background.js:26437:13\n at Generator.next (<anonymous>)\n at fulfilled (chrome-extension://millncjiddlpgdmkklmhfadpacifaonc/dist/background.js:48:24)"
    }
  }
}

the article page says it got refunded, but i did not get the money back

GIVE ME MY MONEY BACK!!! (*angry customer noise*)
Additional Informationthe error message is not very useful for the average user
TagsNo tags attached.
Attached Files

Activities

Christian Grothoff

2023-12-02 11:55

manager   ~0020701

javier: please test, and if this is still an issue, assign to sebasjm.

javier.sepulveda

2023-12-04 09:31

administrator   ~0020720

ACK,

javier.sepulveda

2023-12-04 13:08

administrator   ~0020721

Last edited: 2023-12-04 13:10

I don't see no error here. All the process went smoothly for me. Nothing weird. Working as expected.
The only thing I see in the bottom of the article paid, is a message saying : "Taler allows merchants to offer refunds to customers. This article can't be refunded anymore. ". But I can understand, that is okay.

javier.sepulveda

2023-12-04 13:10

administrator   ~0020722

Seems to be working okay, with no errors.

Issue History

Date Modified Username Field Change
2023-09-14 21:21 davidak New Issue
2023-09-14 21:21 davidak Status new => assigned
2023-09-14 21:21 davidak Assigned To => MS
2023-09-14 21:21 davidak File Added: Screenshot from 2023-09-14 21-13-23.png
2023-09-14 21:21 davidak File Added: Screenshot from 2023-09-14 21-16-23.png
2023-09-14 21:21 davidak File Added: Screenshot from 2023-09-14 21-17-38.png
2023-12-02 11:54 Christian Grothoff Assigned To MS => sebasjm
2023-12-02 11:55 Christian Grothoff Assigned To sebasjm => javier.sepulveda
2023-12-02 11:55 Christian Grothoff Note Added: 0020701
2023-12-02 11:57 Christian Grothoff Target Version => 0.9.6
2023-12-04 09:31 javier.sepulveda Note Added: 0020720
2023-12-04 13:08 javier.sepulveda Note Added: 0020721
2023-12-04 13:08 javier.sepulveda File Added: Screenshot from 2023-12-04 13-05-43.png
2023-12-04 13:08 javier.sepulveda File Added: Screenshot from 2023-12-04 13-05-20.png
2023-12-04 13:10 javier.sepulveda Note Edited: 0020721
2023-12-04 13:10 javier.sepulveda Status assigned => resolved
2023-12-04 13:10 javier.sepulveda Resolution open => fixed
2023-12-04 13:10 javier.sepulveda Note Added: 0020722
2023-12-15 15:36 Christian Grothoff Product Version => git (master)
2023-12-15 15:36 Christian Grothoff Fixed in Version => 0.9.4
2023-12-15 15:36 Christian Grothoff Target Version 0.9.6 => 0.9.4
2024-01-12 14:08 Christian Grothoff Category merchant frontend (blog) => Merchant frontends (Python3)