View Issue Details

IDProjectCategoryView StatusLast Update
0007687Talerwallet-corepublic2023-04-05 18:29
Reportersebasjm Assigned ToFlorian Dold  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Versiongit (master) 
Target Version0.9.3 
Summary0007687: cancel withdrawal from wallet when withdrawal in progress should not lose money
DescriptionFirst case (a)

 1.- initiate a bank withdrawal
 2.- upon math challenge, abort the withdrawal
expected: wallet shows "operation was cancelled by the bank"
current: forever pending

Doing the same operation with manual withdrawal: it make sense to cancel the operation from the wallet since it was initiated by the wallet.
No change needed

Second case (b)

 1.- initiate withdrawal (bank or manual)
 2.- complete the challenge, confirming the wire transfer
 3.- abort the operation in the wallet
expected: exchange returns what was not withdrawn from the wallet
current: no message is shown to the user of the bank that the money is going to be back, this should also consider the scenario that the wallet never withdraw the money and the reserve is timed out
TagsNo tags attached.

Relationships

duplicate of 0007701 resolvedFlorian Dold implement abort semantics from DD37 for withdrawals 

Activities

Florian Dold

2023-04-05 18:29

manager   ~0020032

The two cases described here are just 0007435 and 0007701

Issue History

Date Modified Username Field Change
2023-02-13 20:23 sebasjm New Issue
2023-02-13 20:23 sebasjm Status new => assigned
2023-02-13 20:23 sebasjm Assigned To => Florian Dold
2023-04-05 18:29 Florian Dold Status assigned => resolved
2023-04-05 18:29 Florian Dold Resolution open => duplicate
2023-04-05 18:29 Florian Dold Note Added: 0020032
2023-04-05 18:29 Florian Dold Relationship added duplicate of 0007701
2023-04-13 20:36 Florian Dold Category wallet (TS core) => wallet-core