View Issue Details

IDProjectCategoryView StatusLast Update
0007684Talerspecificationpublic2024-01-10 16:55
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PriorityhighSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.9.4Fixed in Version0.9.4 
Summary0007684: report exchange AML issues in merchant REST API
Descriptionhttps://docs.taler.net/core/api-merchant.html#get--instances-$INSTANCE-private-kyc should report AML status from
600fc4f645286d30cc8446bec1aac466a27a8ec3 (docs.git); GET /deposits/ endpoint of the exchange.
TagsNo tags attached.

Activities

Christian Grothoff

2023-04-10 10:48

manager   ~0020044

79b2673..837416e updates the spec.

Christian Grothoff

2023-04-10 10:48

manager   ~0020045

677ac4a5..090c532b modifies the exchange to return the AML status together with the KYC status.

Christian Grothoff

2023-04-10 11:19

manager   ~0020046

31babe5..208dbea modifies the merchant to expose the AML status in its API. Untested!

Christian Grothoff

2023-04-11 11:01

manager   ~0020063

ad925cc..feaf7ba adds a test.

Christian Grothoff

2023-04-11 11:02

manager   ~0020064

Last step is to add support to the SPA to show a pending/frozen AML state to let the user know why they might not be getting any money ;-). => Assigning to sebasjm.

sebasjm

2023-04-25 04:46

developer   ~0020151

fixed 2f8de9ea8..00f108b9d

if (kyc url !== undefined) => kyc (1)
else if (aml === 1) => AML pending (2)
else => AML frozen (3)

text:
1.- Pending KYC process, click here to complete
2.- There is an anti-money laundering process pending complete
3.- The account is frozen due to the anti-money rules. Contact the exchange service provider for instructions.

Christian Grothoff

2024-01-02 20:36

manager   ~0020815

I just got an order paid but not wired due to KYC required. Alas, the SPA shows nothing about KYC required. Need to investigate who is at fault here.

Christian Grothoff

2024-01-10 16:54

manager   ~0020859

Debugged more, this part is working fine now. New bugs opened ;-).

Issue History

Date Modified Username Field Change
2023-02-13 15:14 Christian Grothoff New Issue
2023-02-13 15:14 Christian Grothoff Status new => assigned
2023-02-13 15:14 Christian Grothoff Assigned To => Christian Grothoff
2023-04-04 16:03 Florian Dold Target Version => 0.9.4
2023-04-08 10:03 Christian Grothoff Priority normal => high
2023-04-10 10:48 Christian Grothoff Note Added: 0020044
2023-04-10 10:48 Christian Grothoff Note Added: 0020045
2023-04-10 11:19 Christian Grothoff Note Added: 0020046
2023-04-11 11:01 Christian Grothoff Note Added: 0020063
2023-04-11 11:01 Christian Grothoff Assigned To Christian Grothoff => sebasjm
2023-04-11 11:02 Christian Grothoff Note Added: 0020064
2023-04-25 04:46 sebasjm Note Added: 0020151
2023-04-25 04:47 sebasjm Assigned To sebasjm => Christian Grothoff
2023-04-25 04:47 sebasjm Status assigned => feedback
2023-09-23 15:51 Christian Grothoff Target Version 0.9.4 => 0.9.5
2024-01-02 20:36 Christian Grothoff Note Added: 0020815
2024-01-10 16:54 Christian Grothoff Note Added: 0020859
2024-01-10 16:55 Christian Grothoff Status feedback => resolved
2024-01-10 16:55 Christian Grothoff Resolution open => fixed
2024-01-10 16:55 Christian Grothoff Fixed in Version => 0.9.4
2024-01-10 16:55 Christian Grothoff Target Version 0.9.5 => 0.9.4
2024-01-12 14:02 Christian Grothoff Category merchant backend API (HTTP specification) => specification