View Issue Details

IDProjectCategoryView StatusLast Update
0007481Talerwallet (TS core)public2023-02-21 16:39
Reportersebasjm Assigned ToFlorian Dold  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Versiongit (master) 
Target Version0.9.2Fixed in Version0.9.2 
Summary0007481: wallet unresponsive when withdrawing high amount of kudos
DescriptionSeems like a lot of coins makes wallet-core unresponsive for long time.

Maybe process a batch of 20 coins.
TagsNo tags attached.

Activities

Florian Dold

2023-02-10 14:18

manager   ~0019796

Fixed now. It was because we were doing the crypto synchronously *and* only scheduled microtasks, i.e. no macrotasks such as other requests were able to run.

Issue History

Date Modified Username Field Change
2022-11-17 18:46 sebasjm New Issue
2022-11-17 18:46 sebasjm Status new => assigned
2022-11-17 18:46 sebasjm Assigned To => Florian Dold
2023-01-11 17:31 Florian Dold Target Version 0.9.1 => 0.9.2
2023-01-11 17:31 Florian Dold Summary wallet crashed when withdrawing high amount of kudos => wallet unresponsive when withdrawing high amount of kudos
2023-02-10 14:18 Florian Dold Status assigned => resolved
2023-02-10 14:18 Florian Dold Resolution open => fixed
2023-02-10 14:18 Florian Dold Note Added: 0019796
2023-02-21 16:39 Christian Grothoff Fixed in Version => 0.9.2
2023-02-21 16:39 Christian Grothoff Status resolved => closed