View Issue Details

IDProjectCategoryView StatusLast Update
0007465Talerwallet (TS core)public2022-11-25 03:16
Reportersebasjm Assigned Tosebasjm  
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.9.1 
Summary0007465: create new attention api
Descriptionmaybe WalletApiOperation.GetNotifications

with level:
 * high: require interaction ASAP or things will happen (like backup expired in less than 1 week, kyc required)
 * medium: required interaction but time expiration is high or not expired
 * low: do not require interaction, like notification

in the UI we may show a badge telling about how many notification are pending

also, show the notification on the top of the tx list? or use another tab?

clicking into one notification will move the user to the notification specific call-to-action.
TagsNo tags attached.

Activities

Florian Dold

2022-11-17 13:56

manager   ~0019434

I really like the name "user attention" for the API, I would prefer it instead of "notification", because that's a very overloaded term. Android has notifications, browser can show notifications, and even the wallet already has a "notification" concept that is purely for the UI implementation to signal that something has changed. It's probably okay to call it "notifications" in the UI though.

Maybe we should show some "show $N more" item/link when we have too many pending transactions or user attention items.

MarcS

2022-11-22 23:15

developer   ~0019472

Last edited: 2022-11-22 23:29

iOS also calls them "Notifications", which could be Banners (to be shown in LockScreen), Badges (red dot with a white number in the top-right corner of the App-Icon) and Sounds.
The user can enable/disable each of these and Apple mandates that the app still works with or without.
If the user enabled LockScreen banners, they are always presented as "stack" if there's more than one active, and the user must tap on the stack to expand it to a (scrollable) list. So we don't need to develop any UI for that, iOS handles it already. We just need to spit out Notifications.
If we have such situation where we would "alert" the user, they still must launch the app (either by selecting a banner in the LockScreen, or launching the app manually). We can then present an overlay screen (or even an alert dialog) which explains the alert situation and ask the user to decide what to do...

There are no levels (hi, medium, lo) however. Since users tend to disable notifications for apps if they annoy with too many too boring disturbances, we should never notificate on low level events - and play sounds only for high level.
On second thought, Badge would be suitable for low level, Badge plus Banner for medium, and Badge plus Banner plus Sound for high level.

sebasjm

2022-11-25 03:16

developer   ~0019479

fixed at e05ba843a061c8050648ce922f36ed3d8e1cf24a

Issue History

Date Modified Username Field Change
2022-11-16 20:12 sebasjm New Issue
2022-11-16 20:12 sebasjm Status new => assigned
2022-11-16 20:12 sebasjm Assigned To => Florian Dold
2022-11-17 13:56 Florian Dold Note Added: 0019434
2022-11-17 13:56 Florian Dold Assigned To Florian Dold => sebasjm
2022-11-22 23:15 MarcS Note Added: 0019472
2022-11-22 23:20 MarcS Note Edited: 0019472
2022-11-22 23:26 MarcS Note Edited: 0019472
2022-11-22 23:29 MarcS Note Edited: 0019472
2022-11-25 03:16 sebasjm Status assigned => resolved
2022-11-25 03:16 sebasjm Resolution open => fixed
2022-11-25 03:16 sebasjm Note Added: 0019479