View Issue Details

IDProjectCategoryView StatusLast Update
0007443Talerwallet (WebExtensions)public2022-11-18 22:42
Reporteroec Assigned ToFlorian Dold  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.9.1Fixed in Version0.9.1 
Summary0007443: Cannot build webextension
Description`make webextension` fails
Steps To Reproduce⋯ ode/wallet-core • make webextension
pnpm install --frozen-lockfile --filter @gnu-taler/taler-wallet-webextension...
Scope: 5 of 13 workspace projects
Lockfile is up to date, resolution step is skipped
. | +135 -123 ++++++++++++++------------
Progress: resolved 135, reused 135, downloaded 0, added 0, done
packages/pogen prepare$ tsc
└─ Done in 2s
packages/taler-util prepare$ tsc
└─ Done in 2.5s
packages/idb-bridge prepare$ tsc
└─ Done in 7s
packages/taler-wallet-core prepare$ tsc
└─ Done in 2.3s
packages/taler-wallet-webextension prepare$ pnpm compile
│ > @gnu-taler/taler-wallet-webextension@0.9.0 compile /home/oec/projects/diss/code/wallet-core/packages
│ > tsc && ./build-fast-with-linaria.mjs
│ node:internal/errors:465
│ ErrorCaptureStackTrace(err);
│ ^
│ Error [ERR_MODULE_NOT_FOUND]: Cannot find package '@linaria/esbuild' imported from /home/oec/projects/
│ at new NodeError (node:internal/errors:372:5)
│ at packageResolve (node:internal/modules/esm/resolve:954:9)
│ at moduleResolve (node:internal/modules/esm/resolve:1003:20)
│ at defaultResolve (node:internal/modules/esm/resolve:1218:11)
│ at ESMLoader.resolve (node:internal/modules/esm/loader:580:30)
│ at ESMLoader.getModuleJob (node:internal/modules/esm/loader:294:18)
│ at ModuleWrap.<anonymous> (node:internal/modules/esm/module_job:80:40)
│ at link (node:internal/modules/esm/module_job:78:36) {
│ code: 'ERR_MODULE_NOT_FOUND'
│ }
│  ELIFECYCLE  Command failed with exit code 1.
└─ Failed in 11.2s
 ELIFECYCLE  Command failed with exit code 1.
make: *** [Makefile:77: webextension] Fehler 1
Additional InformationWorking on commit 5664c6c9b3493f0e44ce065514c51964f9d5b8ba.
TagsNo tags attached.

Activities

Florian Dold

2022-11-07 14:05

manager   ~0019368

Last edited: 2022-11-07 14:05

Looks like the dependency on esbuild was missing. Could you try again with 2431f1b4?

sebasjm

2022-11-07 14:25

developer   ~0019369

that dependency was already declared in root package.json and is installed on the first `make compile`

Makefile generation should be revisited, my proposal is
`make` with no target should install/update all dependencies

oec

2022-11-07 14:34

developer   ~0019370

`make compile` doesn't seem to be mentioned anywhere, no?

I'm tempted to open a bug to unify the expected behavior for `make` and `make install` in _all_ projects, WDYS?

oec

2022-11-07 14:38

developer   ~0019371

The call to `make compile` resolved the missing dependency and compiled the webextension successfully.

Florian Dold

2022-11-07 14:41

manager   ~0019373

@sebasjm: I think that "make install" (and probably plain "make" as well) must ensure that dependencies from the root package.json are also fetched.

Issue History

Date Modified Username Field Change
2022-11-07 13:43 oec New Issue
2022-11-07 13:43 oec Status new => assigned
2022-11-07 13:43 oec Assigned To => Florian Dold
2022-11-07 14:01 Florian Dold Assigned To Florian Dold => sebasjm
2022-11-07 14:04 Florian Dold Assigned To sebasjm => Florian Dold
2022-11-07 14:05 Florian Dold Note Added: 0019368
2022-11-07 14:05 Florian Dold Status assigned => feedback
2022-11-07 14:05 Florian Dold Note Edited: 0019368
2022-11-07 14:25 sebasjm Note Added: 0019369
2022-11-07 14:34 oec Note Added: 0019370
2022-11-07 14:34 oec Status feedback => assigned
2022-11-07 14:38 oec Status assigned => resolved
2022-11-07 14:38 oec Resolution open => fixed
2022-11-07 14:38 oec Note Added: 0019371
2022-11-07 14:41 Florian Dold Note Added: 0019373
2022-11-18 22:42 Christian Grothoff Target Version => 0.9.1
2022-11-18 22:42 Christian Grothoff Fixed in Version => 0.9.1