View Issue Details

IDProjectCategoryView StatusLast Update
0007436Talerwallet (WebExtensions)public2022-11-18 22:42
ReporterFlorian Dold Assigned Tosebasjm  
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.9 
Target Version0.9.1Fixed in Version0.9.1 
Summary0007436: manual withdrawal with IBAN is rendered weirdly
DescriptionFirst of all, I didn't find where to copy the payto:// URI for this directly.

Then, it shows "SANDBOXX/DE159593" as the IBAN, which is not a valid IBAN.
TagsNo tags attached.

Activities

Christian Grothoff

2022-11-06 23:13

manager   ~0019359

payto://-URI parser should split of the BIC from the IBAN, and UIs should allow both to be copied separately.

Christian Grothoff

2022-11-06 23:13

manager   ~0019360

We should check that Android is doing this correctly as well, before resolving the bug.

sebasjm

2022-11-07 14:39

developer   ~0019372

BIC and IBAN is rendered in different fields since commit 661469f8

should we show payto uri? doesn't seem like a normal user will prefer that over the account information.
maybe the display it under devmode?

Christian Grothoff

2022-11-07 15:26

manager   ~0019374

We should also show the payto://-URI (and/or allow copying it to the clipboard), as our bank UI does support sending money to a payto://-URI explicitly already. And we want to promote RFC 8905 ;-).

But, it doesn't need to be too prominent, so I'd show it below the other information in a separate section or box. (I'd show it with a link to RFC 8905 in the label, a copy-to-clipboard button and the payto://-URI as text).

sebasjm

2022-11-07 19:12

developer   ~0019383

roger that

fixed at ca2b4d8c80d208038e99d3b7be8d8e398dc71067

Issue History

Date Modified Username Field Change
2022-11-04 20:51 Florian Dold New Issue
2022-11-04 20:51 Florian Dold Status new => assigned
2022-11-04 20:51 Florian Dold Assigned To => Florian Dold
2022-11-06 23:12 Christian Grothoff Assigned To Florian Dold => sebasjm
2022-11-06 23:13 Christian Grothoff Note Added: 0019359
2022-11-06 23:13 Christian Grothoff Severity minor => tweak
2022-11-06 23:13 Christian Grothoff Product Version => 0.9
2022-11-06 23:13 Christian Grothoff Target Version => 0.9.1
2022-11-06 23:13 Christian Grothoff Note Added: 0019360
2022-11-07 14:39 sebasjm Note Added: 0019372
2022-11-07 14:39 sebasjm Status assigned => feedback
2022-11-07 14:39 sebasjm Assigned To sebasjm => Florian Dold
2022-11-07 15:26 Christian Grothoff Note Added: 0019374
2022-11-07 15:26 Christian Grothoff Assigned To Florian Dold => sebasjm
2022-11-07 19:12 sebasjm Status feedback => resolved
2022-11-07 19:12 sebasjm Resolution open => fixed
2022-11-07 19:12 sebasjm Note Added: 0019383
2022-11-18 22:42 Christian Grothoff Fixed in Version => 0.9.1