View Issue Details

IDProjectCategoryView StatusLast Update
0007385Talerwallet (TS core)public2022-11-04 20:52
Reporterttn Assigned Tosebasjm  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Versiongit (master) 
Target Version0.9Fixed in Version0.9 
Summary0007385: CS 2.1.1 (LEVEL A) -- Keyboard
DescriptionAll functionality of the content is operable through a keyboard interface without
requiring specific timings for individual keystrokes, except where the underlying
function requires input that depends on the path of the user's movement and not
just the endpoints.

The language switch functionality isn't accessible with a
keyboard. This issue is present on all pages, for example:
https://demo.taler.net/en/

--
I think this means we need to create keymaps and bind keys to actions, in them.
TagsNo tags attached.

Activities

sebasjm

2022-10-18 20:00

developer   ~0019227

WIP
a will move the div into a button and test it

sebasjm

2022-10-19 01:02

developer   ~0019231

trying different implementation I'm finally choosing the toggle class using javascript.
since the lang selector is a button is now accessible using the tab, clickable and key-pressable (with space and enter) which is good enough
https://developer.mozilla.org/en-US/docs/Web/Accessibility/Understanding_WCAG/Keyboard

applied to demo frontend at 3d0338d802c27cfcbd0c3d2de6b2135ded0cdd7d

sebasjm

2022-10-19 08:07

developer   ~0019241

all demo pages

Issue History

Date Modified Username Field Change
2022-10-10 21:41 ttn New Issue
2022-10-10 21:41 ttn Status new => assigned
2022-10-10 21:41 ttn Assigned To => sebasjm
2022-10-18 20:00 sebasjm Note Added: 0019227
2022-10-19 01:02 sebasjm Note Added: 0019231
2022-10-19 08:07 sebasjm Status assigned => resolved
2022-10-19 08:07 sebasjm Resolution open => fixed
2022-10-19 08:07 sebasjm Note Added: 0019241
2022-10-20 10:47 Christian Grothoff Fixed in Version => 0.9
2022-10-20 10:48 Christian Grothoff Target Version git (master) => 0.9
2022-11-04 20:52 Christian Grothoff Status resolved => closed