View Issue Details

IDProjectCategoryView StatusLast Update
0007364Talerdocumentationpublic2022-09-19 08:20
Reporterttn Assigned Tottn  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versiongit (master) 
Summary0007364: reseat "Back-office Web service manual"
DescriptionThis chapter (curently 9): https://docs.taler.net/taler-backoffice-manual.html
can seem out of place and too short. It should be integrated elsewhere in the doc tree.
TagsNo tags attached.

Activities

ttn

2022-09-17 01:22

developer   ~0019140

CG adds in off-list mail:

We should then
also update the links from docs.html.j2 (www.git) accordingly, to point
towards whatever documentation we have on the merchant SPA.

[Adding it here in order to not forget.]

ttn

2022-09-17 01:23

developer   ~0019141

I notice, too, that:

- https://docs.taler.net/taler-backoffice-manual.html

mentions Python 3.7, which might be getting long in the tooth
nowadays. I wonder if our code is version agnostic (or "future
proof", or "upward compatible") enough that we can drop that
particular blurb from the documentation. Hmmm.

Christian Grothoff

2022-09-17 22:51

manager   ~0019142

I'm pretty sure >= Python 3.7 should suffice.

sebasjm

2022-09-17 23:45

developer   ~0019143

AFAIK this backoffice is not being used and it's just replaced by the backoffice SPA which is deployed with the merchant backend.

I think we can just remove this documentation.

Christian Grothoff

2022-09-18 00:07

manager   ~0019144

Yes, that's what I was thinking. Is there any reasonable documentation for the SPA we can link to instead (from docs.html)? Anything to preserve?

ttn

2022-09-19 08:20

developer   ~0019145

Since that manual is no longer useful, it was deleted:

https://git.taler.net/docs.git/commit/?id=c91d277094ef0c6d58fa727fa0923eb17bbf139d

Closing.

(If we need to document SPA interaction in the merchant manual, we can open a new issue.)

Issue History

Date Modified Username Field Change
2022-09-17 01:18 ttn New Issue
2022-09-17 01:18 ttn Status new => assigned
2022-09-17 01:18 ttn Assigned To => ttn
2022-09-17 01:22 ttn Note Added: 0019140
2022-09-17 01:23 ttn Note Added: 0019141
2022-09-17 22:51 Christian Grothoff Note Added: 0019142
2022-09-17 23:45 sebasjm Note Added: 0019143
2022-09-18 00:07 Christian Grothoff Note Added: 0019144
2022-09-19 08:20 ttn Status assigned => resolved
2022-09-19 08:20 ttn Resolution open => fixed
2022-09-19 08:20 ttn Note Added: 0019145