View Issue Details

IDProjectCategoryView StatusLast Update
0007305Talerwallet (TS core)public2022-09-02 15:37
Reportersebasjm Assigned Tosebasjm  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Versiongit (master) 
Summary0007305: can't pay an order without age restriction (excgabge wutg age restriction denoms enabled)
DescriptionI have this setup

taler-wallet-cli 0.9.0-dev.2-4ca38113
taler-exchange-httpd v0.8.5-git-a199ba7f
taler-merchant-httpd v0.8.4-git-1a627443
libeufin-cli, version 0.0.1-dev.1

the exchange has denominations with age_restricted = yes

When trying to pay an order without age restriction I get an error from the merchant

{
  "code": 7005,
  "hint": "Unexpected HTTP status (400) in response",
  "requestUrl": "http://merchant-backend.taler:9966/orders/2022.234-W09HC1QM145G6/pay",
  "httpStatusCode": 400,
  "errorResponse": {
    "hint": "The payment required no minimum age but one of the coins (of a denomination with support for age restriction) did not provide the required h_age_commitment.",
    "code": 2174,
    "h_denom_pub": "8A15T6PQVVW1BX65P4K719M749K6DPFDFD8Q99TCZQPW2X13HNYB4B19JZNDZD0E0H3K9DS65AAFCDW261DTWRQ0BE3RVAQAKVM185G"
  }
}




TagsNo tags attached.

Activities

sebasjm

2022-08-22 17:43

developer   ~0019022

cc @oec

oec

2022-08-23 17:09

developer   ~0019029

Mhh, commit aff3100d8901fe16a7e635945edfdad6f08fdf37 in wallet-core should have fixed that. Do you have any debug output (details of the coins in the wallet f.e.)?

sebasjm

2022-08-30 17:31

developer   ~0019075

I will try to reproduce this issue again and add more information.

sebasjm

2022-09-02 15:34

developer   ~0019078

I couldn't reproduce the issue with the latest commit from master 9fe0e742
then I saw @florian commit it's about age restr and it seems that that fixed the issue

sebasjm

2022-09-02 15:37

developer   ~0019079

I have also tested on ec43b6a5 and it did reproduce the issue
(withdraw and pay an order without age restriction)

Issue History

Date Modified Username Field Change
2022-08-22 17:35 sebasjm New Issue
2022-08-22 17:35 sebasjm Status new => assigned
2022-08-22 17:35 sebasjm Assigned To => Florian Dold
2022-08-22 17:43 sebasjm Note Added: 0019022
2022-08-23 09:09 oec Assigned To Florian Dold => oec
2022-08-23 17:09 oec Note Added: 0019029
2022-08-30 17:23 sebasjm Assigned To oec => sebasjm
2022-08-30 17:31 sebasjm Note Added: 0019075
2022-09-02 15:34 sebasjm Note Added: 0019078
2022-09-02 15:37 sebasjm Status assigned => resolved
2022-09-02 15:37 sebasjm Resolution open => fixed
2022-09-02 15:37 sebasjm Note Added: 0019079