View Issue Details

IDProjectCategoryView StatusLast Update
0007284Talerexchangepublic2022-07-22 12:46
Reporteroec Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versiongit (master) 
Fixed in Versiongit (master) 
Summary0007284: make check fails in bank-lib
Descriptiontest_bank.sh fails:

```

Launching bank....OK
Making wire transfer to exchange ...2022-07-20T18:11:15.397787+0200 util-disk-3984761 WARNING `stat' failed on file `/etc/taler/conf.d' at disk.c:836 with error: No such file or directory
2022-07-20T18:11:15.397887+0200 taler-wire-gateway-client-3984761 ERROR Failed to parse configuration file `/etc/taler/taler.conf'
2022-07-20T18:11:15.397906+0200 util-3984761 WARNING Failed to load configuration from file '/etc/taler/taler.conf'
2022-07-20T18:11:15.397921+0200 taler-wire-gateway-client-3984761 ERROR Malformed configuration. Exiting ...
FAIL test_bank.sh (exit status: 3)

```

There is no /etc/taler/conf.d on my system, their never was. Yet, this error message shows up the first time. It seems to have trouble with the line

```
@inline-matching@ conf.d/*.conf
```

in /etc/taler/taler.conf

Issue with GNUnet!?
Steps To Reproduceafter git pull && make install:

```
⋯ /bank-lib [?=2] • make check
make test_bank.sh
make[1]: Entering directory '/home/oec/projects/diss/code/exchange/src/bank-lib'
make[1]: Nothing to be done for 'test_bank.sh'.
make[1]: Leaving directory '/home/oec/projects/diss/code/exchange/src/bank-lib'
make check-TESTS
make[1]: Entering directory '/home/oec/projects/diss/code/exchange/src/bank-lib'
make[2]: Entering directory '/home/oec/projects/diss/code/exchange/src/bank-lib'
FAIL: test_bank.sh
============================================================================
Testsuite summary for taler-exchange 0.8.5
============================================================================
# TOTAL: 1
# PASS: 0
# SKIP: 0
# XFAIL: 0
# FAIL: 1
# XPASS: 0
# ERROR: 0
============================================================================
See src/bank-lib/test-suite.log
Please report to taler-bug@gnunet.org
============================================================================
make[2]: *** [Makefile:975: test-suite.log] Error 1
make[2]: Leaving directory '/home/oec/projects/diss/code/exchange/src/bank-lib'
make[1]: *** [Makefile:1083: check-TESTS] Error 2
make[1]: Leaving directory '/home/oec/projects/diss/code/exchange/src/bank-lib'
make: *** [Makefile:1156: check-am] Error 2
```

```
⋯ /bank-lib [?=2] • cat test-suite.log
=======================================================
   taler-exchange 0.8.5: src/bank-lib/test-suite.log
=======================================================

# TOTAL: 1
# PASS: 0
# SKIP: 0
# XFAIL: 0
# FAIL: 1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: test_bank.sh
==================

Launching bank....OK
Making wire transfer to exchange ...2022-07-20T18:11:15.397787+0200 util-disk-3984761 WARNING `stat' failed on file `/etc/taler/conf.d' at disk.c:836 with error: No such file or directory
2022-07-20T18:11:15.397887+0200 taler-wire-gateway-client-3984761 ERROR Failed to parse configuration file `/etc/taler/taler.conf'
2022-07-20T18:11:15.397906+0200 util-3984761 WARNING Failed to load configuration from file '/etc/taler/taler.conf'
2022-07-20T18:11:15.397921+0200 taler-wire-gateway-client-3984761 ERROR Malformed configuration. Exiting ...
FAIL test_bank.sh (exit status: 3)
```

TagsNo tags attached.

Activities

Christian Grothoff

2022-07-21 16:38

manager   ~0018962

It is very strange that your test suite looks for anything in /etc/, it should not. What did you set $TALER_PREFIX to?

oec

2022-07-21 17:37

developer   ~0018963

$TALER_PREFIX is not set in my environment manually.

oec

2022-07-22 12:46

developer   ~0018968

Turns out that for anastatis (which failed to build on my system) I had libgnunet from the taler repository installed. That one did not have the commit 78cba4124a993ba97923ff0543f2a5942f297cdc which drops "t_ms" in the date encoding.

The culprit was the encoding of the "date" field in this json blob:

```
{
  "incoming_transactions": [
    {
      "row_id": 2,
      "amount": "TESTKUDOS:10.00",
      "date": {
        "t_ms": 1658485223000
      },
      "reserve_pub": "7B79SWFRV596BWH221VVPA847P4YRQ3CWAP4EPRNJA2RQ1G3JH2G",
      "credit_account": "payto://x-taler-bank/localhost/Exchange",
      "debit_account": "payto://x-taler-bank/localhost/testuser-tlafj3u2"
    }
  ]
}
```

After an `apt remove libgnunet`, `make check` passes in bank-lib.

Issue History

Date Modified Username Field Change
2022-07-20 18:18 oec New Issue
2022-07-20 18:18 oec Status new => assigned
2022-07-20 18:18 oec Assigned To => Christian Grothoff
2022-07-21 16:38 Christian Grothoff Note Added: 0018962
2022-07-21 17:37 oec Note Added: 0018963
2022-07-22 12:46 oec Status assigned => resolved
2022-07-22 12:46 oec Resolution open => fixed
2022-07-22 12:46 oec Fixed in Version => git (master)
2022-07-22 12:46 oec Note Added: 0018968