View Issue Details

IDProjectCategoryView StatusLast Update
0007261Talerdocumentationpublic2022-06-29 19:28
Reporterttn Assigned Tottn  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version20.04.04
Product Versiongit (master) 
Summary0007261: Ubuntu 20.04 does not have PostgreSQL 13
DescriptionPostgreSQL 13 is not available OOTB (in the "default" set of sources.list targets).
Either we need to find/document how to augment sources.list and thus install PostgreSQL 13,
or we revisit the suitability of Ubuntu 20.04 and jump to the next LTS version (that has PostgreSQL 13 OOTB).

BTW, latest LTS version (of Ubuntu server) is 22.04:
https://ubuntu.com/download/server
TagsNo tags attached.

Activities

ttn

2022-06-14 09:49

developer   ~0018928

Detailed instructions (recently published, too!) at:
https://computingforgeeks.com/how-to-install-postgresql-13-on-ubuntu

ttn

2022-06-28 08:25

developer   ~0018941

Work has started on this:
- https://git.taler.net/docs.git/commit/?id=92bce84189723212ee42e1032730623f59f9ac39
- https://git.taler.net/docs.git/commit/?id=95160df8438a3dd408352d66b7f4464719b05409

ttn

2022-06-28 08:30

developer   ~0018942

Looks like 22.04 does indeed have PostgreSQL 13 (since it has 14):
https://discourse.ubuntu.com/t/jammy-jellyfish-release-notes/24668

ttn

2022-06-29 07:52

developer   ~0018947

Installation of taler-exchange, taler-exchange-offline, taler-merchant, taler-wallet-cli on 22.04 works w/o incident.
There is, however, a small problem on uninstall (see 0007265).

ttn

2022-06-29 07:54

developer   ~0018948

Also, GPG key addition via apt-key is deprecated in 22.04:
https://manpages.debian.org/testing/apt/apt-key.8.en.html

ttn

2022-06-29 19:28

developer   ~0018950

These commits resolve the issue (for the Ubuntu-related frag):
- https://git.taler.net/docs.git/commit/?id=7fb6183602295e3dd5c98d64a2ee1cf00ee83bf7
- https://git.taler.net/docs.git/commit/?id=0458b1caa0bb2d2ae46c61acfbf8be193aecd897

Other docs still mention Focal Fossa, but that's a separate issue.

Issue History

Date Modified Username Field Change
2022-06-14 09:45 ttn New Issue
2022-06-14 09:45 ttn Status new => assigned
2022-06-14 09:45 ttn Assigned To => ttn
2022-06-14 09:49 ttn Note Added: 0018928
2022-06-28 08:25 ttn Note Added: 0018941
2022-06-28 08:30 ttn Note Added: 0018942
2022-06-29 07:50 ttn Relationship added parent of 0007265
2022-06-29 07:52 ttn Note Added: 0018947
2022-06-29 07:54 ttn Note Added: 0018948
2022-06-29 19:23 ttn Relationship deleted parent of 0007265
2022-06-29 19:28 ttn Status assigned => resolved
2022-06-29 19:28 ttn Resolution open => fixed
2022-06-29 19:28 ttn Note Added: 0018950