View Issue Details

IDProjectCategoryView StatusLast Update
0007218Anastasisanastasis-gtkpublic2022-04-06 14:33
ReporterFlorian Dold Assigned ToChristian Grothoff  
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Fixed in VersionGit master 
Summary0007218: "Solve challenges" screen complains about "A challenge is already active"
DescriptionWhen doing email auth, clicking the "solve" button and then clicking "cancel" results in a state where I can't try to solve the challenge anymore, because clicking the solve button tries to do a "POST .../challenge" again, which fails. Instead, the user should just be prompted for the code sent via email.

Not sure if the issue is with the reducer or the UI, but I'd guess the former.
TagsNo tags attached.

Activities

Christian Grothoff

2022-04-06 14:33

manager   ~0018855

Fixed in Git master (anastasis.git).

Issue History

Date Modified Username Field Change
2022-04-06 13:48 Florian Dold New Issue
2022-04-06 13:48 Florian Dold Status new => assigned
2022-04-06 13:48 Florian Dold Assigned To => Christian Grothoff
2022-04-06 14:33 Christian Grothoff Status assigned => resolved
2022-04-06 14:33 Christian Grothoff Resolution open => fixed
2022-04-06 14:33 Christian Grothoff Fixed in Version => Git master
2022-04-06 14:33 Christian Grothoff Note Added: 0018855