View Issue Details

IDProjectCategoryView StatusLast Update
0007179Talerwallet (WebExtensions)public2022-11-04 20:52
Reportersebasjm Assigned Tosebasjm  
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Versiongit (master) 
Target Version0.9Fixed in Version0.9 
Summary0007179: design & implement "cta template" for every type of tx
Descriptionuse cases by transaction:

 * withdraw: check fees and confirm the action of getting coins from an exchange
 * payment: check the contract, fee and confirm the payment
 * refund: ask refund to the merchant if the contract terms allows the user for it
 * deposit: redeem your coins and ask the exchange for a wire transfer to the user account
 * tip: redeem coins into someone's account

Take into account that these actions may be initiated by some webpage link, like refund here
https://shop.demo.taler.net/en/essay/Freedom_of_Speech-_Press-_and_Association_on_the_Internet

TagsNo tags attached.

Activities

belen

2022-03-15 18:37

developer   ~0018797

After some discussion with Florian and Sebastian on 15 March we agreed that we don't need a refund page.

belen

2022-03-15 19:31

developer   ~0018798

Scratch the above comment. It turns out we do need a 'cta' page for refunds!

Florian, Sebastian and Belen had a long conversation during the weekly call on 15 March about how a refund should take place. This is a summary of the process as I understood it:

1. The user is the one starting the refund process. She does so by visiting the purchase page in the merchant's website and clicking an "I want a refund" button.

2. When the user clicks this button, the page displays a QR code or triggers the web extension.

3. When I scan the QR with my mobile, the mobile wallet shows me a screen with the refund details (e.g. amount, merchant, etc). This screen includes a button to 'accept' the refund, and another button to 'reject' the refund. A similar page will be shown in the web extension. This page may not be required from a technical perspective, but it is needed from an interaction design perspective: users should be shown the details of the transaction before it takes place, so that they remain informed about what the system is doing and in control of the process. Executing the refund straight away upon scanning a QR code would be just a tad too fast for the human brain. People may struggle understanding what has happened.

4. If the user accepts the refund they will see a notification confirming that the amount has been refunded. The merchant should be notified that the user has accepted the refund.

5. If the user rejects the refund, the merchant should be notified that the refund has been rejected and the refund should be cancelled.

If any of the above is incorrect, please comment on the issue!

Issue History

Date Modified Username Field Change
2022-02-23 15:54 sebasjm New Issue
2022-02-23 15:54 sebasjm Status new => assigned
2022-02-23 15:54 sebasjm Assigned To => sebasjm
2022-03-15 18:37 belen Note Added: 0018797
2022-03-15 19:31 belen Note Added: 0018798
2022-07-17 16:32 sebasjm Status assigned => resolved
2022-07-17 16:32 sebasjm Resolution open => fixed
2022-10-20 10:47 Christian Grothoff Fixed in Version => 0.9
2022-10-20 10:48 Christian Grothoff Target Version git (master) => 0.9
2022-11-04 20:52 Christian Grothoff Status resolved => closed