View Issue Details

IDProjectCategoryView StatusLast Update
0007082Anastasisanastasis-gtkpublic2021-11-27 21:18
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Fixed in Version0.3.0 
Summary0007082: save-as button confusing during recovery
DescriptionWhen selecting the challenge, a user repeatedly tried the 'save as' button instead of selecting a challenge.
The 'save as' button is misplaced and should not be in the place of the 'next' button in this dialog.
Furthermore, the WebUI seems better for user to be able to identify where they need to click to select the challenge.
=> replace dialog design with the one from WebUI as far as possible.
TagsNo tags attached.

Activities

Christian Grothoff

2021-11-10 21:28

manager   ~0018470

Some users also confused the upper half of the challenge selection dialog with the non-interactive lower-half, trying to select a challenge in the lower half. Again, the WebUI dialog does not have this issue.

Christian Grothoff

2021-11-16 18:38

manager   ~0018494

Belen proposes to move the 'save as' below 'backup completed' (below the tree view) to move it away from 'next'.

Christian Grothoff

2021-11-21 18:59

manager   ~0018518

e8e8396..64d6b24 moves the save-as button to the location suggested by Belen.

Christian Grothoff

2021-11-21 23:12

manager   ~0018520

64d6b24..9142443 works towards changing the challenge selection dialog to be more like in the WebUI.
However, rendering of challenge feedback is not implemented, and I could not test it due to some unrelated bug that needs debugging first...

Christian Grothoff

2021-11-27 21:18

manager   ~0018558

Fixed in 9f7ef95..9a19858

Issue History

Date Modified Username Field Change
2021-11-10 21:22 Christian Grothoff New Issue
2021-11-10 21:22 Christian Grothoff Status new => assigned
2021-11-10 21:22 Christian Grothoff Assigned To => Christian Grothoff
2021-11-10 21:28 Christian Grothoff Note Added: 0018470
2021-11-16 18:38 Christian Grothoff Note Added: 0018494
2021-11-21 18:59 Christian Grothoff Note Added: 0018518
2021-11-21 23:12 Christian Grothoff Note Added: 0018520
2021-11-27 21:18 Christian Grothoff Status assigned => resolved
2021-11-27 21:18 Christian Grothoff Resolution open => fixed
2021-11-27 21:18 Christian Grothoff Fixed in Version => 0.3.0
2021-11-27 21:18 Christian Grothoff Note Added: 0018558