View Issue Details

IDProjectCategoryView StatusLast Update
0007063AnastasisC reducer implementationpublic2022-04-14 21:29
ReporterFlorian Dold Assigned ToFlorian Dold  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionGit master 
Target Version0.3.0Fixed in Version0.3.0 
Summary0007063: C reducer upload fee computation includes providers that are not part of any policy
DescriptionIn ./test_anastasis_reducer_enter_secret.sh, only two providers are used in the policies.

However, the upload fees that the test case expects (and that the C reducer computes) include the annual fees of a four available providers.
TagsNo tags attached.

Activities

Florian Dold

2021-11-03 10:56

manager   ~0018452

This is actually even more confusing, since the start state used for the fees computation (resources/06-backup.json) only has two providers in the policy_providers, and the two entries are the same (!!), so this is a broken state ...

Christian Grothoff

2021-11-06 17:35

manager   ~0018461

I thought we had discussed this: right now, we upload the policy document to all providers that have not been disabled.

Issue History

Date Modified Username Field Change
2021-11-03 10:49 Florian Dold New Issue
2021-11-03 10:49 Florian Dold Status new => assigned
2021-11-03 10:49 Florian Dold Assigned To => Christian Grothoff
2021-11-03 10:56 Florian Dold Note Added: 0018452
2021-11-06 17:35 Christian Grothoff Status assigned => feedback
2021-11-06 17:35 Christian Grothoff Note Added: 0018461
2021-11-06 17:35 Christian Grothoff Assigned To Christian Grothoff => Florian Dold
2022-04-14 21:29 Christian Grothoff Status feedback => resolved
2022-04-14 21:29 Christian Grothoff Resolution open => fixed
2022-04-14 21:29 Christian Grothoff Fixed in Version => 0.3.0
2022-04-14 21:29 Christian Grothoff Product Version => Git master
2022-04-14 21:29 Christian Grothoff Target Version => 0.3.0