View Issue Details

IDProjectCategoryView StatusLast Update
0007046Anastasisanastasis-gtkpublic2021-11-06 12:13
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionGit master 
Target Version0.3.0Fixed in Version0.3.0 
Summary0007046: birth date selection sometimes freezes up "next" button
DescriptionWhen doing a Testland, I tried to enter the birth date "2020-01-01" (because that's what I used as input to the webui).

However, when I try to select this date, the "next" button freezes up. Even if I select some earlier date, it doesn't unfreeze. I need to re-start the application to unfreeze the button and use some different date.

The exact order of how I'm doing things:
1. use "year forward" button until I'm in 2020
2. use "month back" button until I'm in January
3. select the first
4. enter name and square number (using 4)
TagsNo tags attached.

Activities

Florian Dold

2021-10-19 21:11

manager   ~0018442

Huh looks like "January" is simply broken and freezes up the "next" button.

Florian Dold

2021-10-19 21:14

manager   ~0018443

Furthermore, the birth date given to the reducer is simply bogus. The 28th of February is stored as 1980-01-28.

Looks like some off-by-one ...

Issue History

Date Modified Username Field Change
2021-10-19 21:07 Florian Dold New Issue
2021-10-19 21:07 Florian Dold Status new => assigned
2021-10-19 21:07 Florian Dold Assigned To => Christian Grothoff
2021-10-19 21:11 Florian Dold Note Added: 0018442
2021-10-19 21:14 Florian Dold Note Added: 0018443
2021-11-06 12:13 Christian Grothoff Status assigned => resolved
2021-11-06 12:13 Christian Grothoff Resolution open => fixed
2021-11-06 12:13 Christian Grothoff Fixed in Version => 0.3.0
2021-11-06 12:13 Christian Grothoff Product Version => Git master
2021-11-06 12:13 Christian Grothoff Target Version => 0.3.0