View Issue Details

IDProjectCategoryView StatusLast Update
0007019Talerdocumentationpublic2021-11-27 09:28
ReporterChristian Grothoff Assigned Tottn  
PrioritynormalSeveritytextReproducibilityN/A
Status assignedResolutionreopened 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.9Fixed in Version0.9 
Summary0007019: man pages missing for sync commands
DescriptionSpecifically, sync-httpd and sync-dbinit. Should be very similar to the other -httpd and -dbinit commands.
Also, it would be good if we had a man page for the various options of sync (man 5 sync.conf). Once those are written, we need to import the 'prebuilt' submodule into sync.git, modify the build system to include the man pages (sync-only) and update the Debian packaging of sync.
TagsNo tags attached.

Activities

ttn

2021-11-24 16:06

developer   ~0018527

See for a start: https://git.taler.net/docs.git/commit/?id=e3cc1ff85bf01145b4a8e9865c5832e0dce53a16

Feedback welcome!

Christian Grothoff

2021-11-24 17:42

manager   ~0018528

Looks good to me!

ttn

2021-11-24 21:26

developer   ~0018532

Re-opening since the sync.conf(5) page hasn't yet been written (WIP).

ttn

2021-11-24 22:12

developer   ~0018534

Question: Is the sync.conf syntax the same as taler.conf syntax?
(Perhaps we can factor out the common text into frags/conf-syntax-rst, or somesuch.)

Christian Grothoff

2021-11-25 00:09

manager   ~0018537

Yes.

ttn

2021-11-26 23:43

developer   ~0018554

I just realized there is also a need for sync-config(1) manpage.

ttn

2021-11-26 23:52

developer   ~0018555

See https://git.taler.net/docs.git/commit/?id=95a7133ef140bf285ef5640ad9db250b13f16301
for a s/taler-config/sync-config/g treatment.

ttn

2021-11-27 00:38

developer   ~0018556

See https://git.taler.net/docs.git/commit/?id=49ed051fd55cc7df9aa84455d1efef6efadf350a

The subsequent commits evenly distribute references to the sync* manpages in the respective See Also sections.

We can probably close this bug now. (I am not familiar w/ how to do the other tasks, maybe that should be in another bug?)

ttn

2021-11-27 09:28

developer   ~0018557

OTOH, thinking more about it, there's no harm if i try the other parts. Let's see how things go...

Issue History

Date Modified Username Field Change
2021-09-17 09:48 Christian Grothoff New Issue
2021-09-17 09:48 Christian Grothoff Status new => assigned
2021-09-17 09:48 Christian Grothoff Assigned To => ttn
2021-11-24 16:06 ttn Note Added: 0018527
2021-11-24 17:42 Christian Grothoff Note Added: 0018528
2021-11-24 17:42 Christian Grothoff Status assigned => resolved
2021-11-24 17:42 Christian Grothoff Resolution open => fixed
2021-11-24 17:42 Christian Grothoff Fixed in Version => 0.9
2021-11-24 17:42 Christian Grothoff Target Version 0.8.5 => 0.9
2021-11-24 21:26 ttn Status resolved => feedback
2021-11-24 21:26 ttn Resolution fixed => reopened
2021-11-24 21:26 ttn Note Added: 0018532
2021-11-24 22:12 ttn Note Added: 0018534
2021-11-25 00:09 Christian Grothoff Note Added: 0018537
2021-11-25 00:09 Christian Grothoff Status feedback => assigned
2021-11-26 23:43 ttn Note Added: 0018554
2021-11-26 23:52 ttn Note Added: 0018555
2021-11-27 00:38 ttn Note Added: 0018556
2021-11-27 09:28 ttn Note Added: 0018557