View Issue Details

IDProjectCategoryView StatusLast Update
0007006GNUnetpostgres librarypublic2021-08-28 21:55
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionGit master 
Target Version0.16.0Fixed in Version0.16.0 
Summary0007006: merchant dbinit does not properly report errors
DescriptionIt just tells me "3".

$ sudo -u taler-merchant-httpd taler-merchant-dbinit -c /etc/taler/taler.conf
2021-08-28T17:17:37.295109+0000 taler-merchant-dbinit-418734 WARNING Could not run PSQL on file /usr/share/taler//sql/merchant/merchant-0000.sql: 3
2021-08-28T17:17:37.295186+0000 taler-merchant-dbinit-418734 ERROR Failed to run SQL logic to setup database versioning logic
2021-08-28T17:17:37.295238+0000 taler-merchant-dbinit-418734 ERROR Failed to initialize tables
TagsNo tags attached.

Activities

Christian Grothoff

2021-08-28 20:23

manager   ~0018139

That's because it doesn't have more: it forks the "psql" binary, and the only thing we have is the psql binary exit code.

Florian Dold

2021-08-28 21:00

developer   ~0018140

Ah. But then why don't we just let psql inherit stderr, so we get a decent error message? And currently the error message *looks* broken. Is the "3" a line number, an exit status or ...? At least we should indicate in the log text that this is the exit status of psql.

Christian Grothoff

2021-08-28 21:54

manager   ~0018141

Fixed error message text and inherited stderr as of 7a4c1fb72..2994fa434

Christian Grothoff

2021-08-28 21:54

manager   ~0018142

(Note that this is a GNUnet change.)

Issue History

Date Modified Username Field Change
2021-08-28 19:22 Florian Dold New Issue
2021-08-28 19:22 Florian Dold Status new => assigned
2021-08-28 19:22 Florian Dold Assigned To => Christian Grothoff
2021-08-28 20:23 Christian Grothoff Note Added: 0018139
2021-08-28 20:23 Christian Grothoff Assigned To Christian Grothoff => Florian Dold
2021-08-28 20:23 Christian Grothoff Status assigned => feedback
2021-08-28 21:00 Florian Dold Note Added: 0018140
2021-08-28 21:54 Christian Grothoff Note Added: 0018141
2021-08-28 21:54 Christian Grothoff Note Added: 0018142
2021-08-28 21:54 Christian Grothoff Status feedback => resolved
2021-08-28 21:54 Christian Grothoff Resolution open => fixed
2021-08-28 21:54 Christian Grothoff Fixed in Version => 0.8.5
2021-08-28 21:55 Christian Grothoff Project Taler => GNUnet
2021-08-28 21:55 Christian Grothoff Category mechant backend => General
2021-08-28 21:55 Christian Grothoff Assigned To Florian Dold => Christian Grothoff
2021-08-28 21:55 Christian Grothoff Category General => postgres library
2021-08-28 21:55 Christian Grothoff Product Version => Git master
2021-08-28 21:55 Christian Grothoff Fixed in Version 0.8.5 => 0.16.0
2021-08-28 21:55 Christian Grothoff Target Version => 0.16.0