View Issue Details

IDProjectCategoryView StatusLast Update
0007004Talermechant backendpublic2021-08-30 16:46
Reportersebasjm Assigned Tosebasjm  
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Versiongit (master) 
Target Version0.8.5Fixed in Version0.8.5 
Summary0007004: problems suspending god
DescriptionIm currently running 20 days old version, commit id c9d29b909d092dc9d5c230f496905fa3a07f64f0

I will report back if I manage to reproduce it on latest master version.

#2 0x00007f4723b8d59b in GNUNET_abort_ () at common_logging.c:281
#3 0x00005608a8deb173 in suspend_god (god=0x5608a9301dc0) at taler-merchant-httpd_get-orders-ID.c:195
#4 0x00005608a8debf56 in send_pay_request (god=0x5608a9301dc0, already_paid_order_id=0x0) at taler-merchant-httpd_get-orders-ID.c:498
#5 0x00005608a8dedeaa in TMH_get_orders_ID (rh=0x5608a8e3f7d0 <public_handlers+720>, connection=0x5608a930a090, hc=0x5608a930d340)
    at taler-merchant-httpd_get-orders-ID.c:1039
#6 0x00005608a8de4066 in url_handler (cls=0x0, connection=0x5608a930a090, url=0x5608a932b3f4 "/orders/2021.239-00RAPSN8JXAK6", method=0x5608a932b3f0 "GET",
    version=0x5608a932b445 "HTTP/1.1", upload_data=0x0, upload_data_size=0x7ffe84dd09a8, con_cls=0x5608a930a0e8) at taler-merchant-httpd.c:1651
#7 0x00007f4723c39c5f in call_connection_handler (connection=connection@entry=0x5608a930a090) at connection.c:2166
#8 0x00007f4723c3b551 in MHD_connection_handle_idle (connection=connection@entry=0x5608a930a090) at connection.c:3459
Steps To Reproducetrying to render order status from merchant backend
TagsNo tags attached.

Activities

Christian Grothoff

2021-08-27 23:11

manager   ~0018136

The line number suggest a substantially out-of-date merchant.git, and I *think* I may have solved this one already. Please really try with Git master for a bit, and if you do not succeed, I think this can be closed.

sebasjm

2021-08-30 16:10

developer   ~0018143

could not reproduce on master, seems fixed

Issue History

Date Modified Username Field Change
2021-08-27 17:55 sebasjm New Issue
2021-08-27 17:55 sebasjm Status new => assigned
2021-08-27 17:55 sebasjm Assigned To => Christian Grothoff
2021-08-27 23:11 Christian Grothoff Status assigned => feedback
2021-08-27 23:11 Christian Grothoff Note Added: 0018136
2021-08-27 23:11 Christian Grothoff Target Version git (master) => 0.8.5
2021-08-27 23:12 Christian Grothoff Assigned To Christian Grothoff => sebasjm
2021-08-30 16:10 sebasjm Status feedback => resolved
2021-08-30 16:10 sebasjm Resolution open => fixed
2021-08-30 16:10 sebasjm Note Added: 0018143
2021-08-30 16:46 Christian Grothoff Fixed in Version => 0.8.5