View Issue Details

IDProjectCategoryView StatusLast Update
0006950Talerexchangepublic2021-08-24 16:22
Reporterttn Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
PlatformLinuxOSDebianOS VersionBullseye/Sid
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006950: "make" fails, referencing TALER_exchange_get_zero in installed lib
DescriptionHEAD is at 44f7a19ab1f1a1b04eeaf72a5965fa82575ad201.
In the logfile (attached), it seems that 'TALER_exchange_get_zero' was referenced
from an installed lib (under /home/ttn/t/lib) rather than from the working directory.
That seems strange to me. Perhaps an error in the order of the CCLD '-L' flags?
TagsNo tags attached.

Activities

ttn

2021-07-23 13:39

developer  

.ttn.exchange-make.log (14,701 bytes)   
-*- mode: compilation; default-directory: "~/build/GNU/T/exchange/" -*-
Compilation started at Fri Jul 23 13:28:46

make -j8
Makefile:963: warning: overriding recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:958: warning: ignoring old recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:968: warning: overriding recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:963: warning: ignoring old recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:973: warning: overriding recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:968: warning: ignoring old recipe for target 'doxygen-doc/taler-exchange.tag'
make  all-recursive
make[1]: Entering directory '/home/ttn/build/GNU/T/exchange'
Makefile:963: warning: overriding recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:958: warning: ignoring old recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:968: warning: overriding recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:963: warning: ignoring old recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:973: warning: overriding recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:968: warning: ignoring old recipe for target 'doxygen-doc/taler-exchange.tag'
Making all in .
make[2]: Entering directory '/home/ttn/build/GNU/T/exchange'
Makefile:963: warning: overriding recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:958: warning: ignoring old recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:968: warning: overriding recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:963: warning: ignoring old recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:973: warning: overriding recipe for target 'doxygen-doc/taler-exchange.tag'
Makefile:968: warning: ignoring old recipe for target 'doxygen-doc/taler-exchange.tag'
make[2]: Leaving directory '/home/ttn/build/GNU/T/exchange'
Making all in contrib
make[2]: Entering directory '/home/ttn/build/GNU/T/exchange/contrib'
Making all in .
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/contrib'
make[3]: Nothing to be done for 'all-am'.
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/contrib'
make[2]: Leaving directory '/home/ttn/build/GNU/T/exchange/contrib'
Making all in src
make[2]: Entering directory '/home/ttn/build/GNU/T/exchange/src'
Making all in include
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/include'
make[3]: Nothing to be done for 'all'.
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/include'
Making all in util
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/util'
  CC       taler-exchange-secmod-eddsa.o
  CC       amount.lo
  CC       auditor_signatures.lo
  CC       config.lo
  CC       crypto.lo
  CC       crypto_helper_denom.lo
  CC       crypto_helper_esign.lo
  CC       crypto_wire.lo
  CC       getopt.lo
  CC       lang.lo
  CC       mhd.lo
  CC       offline_signatures.lo
  CC       payto.lo
  CC       secmod_signatures.lo
  CC       taler_error_codes.lo
  CC       url.lo
  CC       util.lo
  CC       wallet_signatures.lo
  CC       yna.lo
  CC       os_installation.lo
  CC       taler-exchange-secmod-rsa.o
  CCLD     libtalerutil.la
  CCLD     taler-exchange-secmod-eddsa
  CCLD     taler-exchange-secmod-rsa
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/util'
Making all in json
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/json'
  CC       i18n.lo
  CC       json.lo
  CC       json_helper.lo
  CC       json_wire.lo
  CCLD     libtalerjson.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/json'
Making all in curl
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/curl'
  CC       curl.lo
  CCLD     libtalercurl.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/curl'
Making all in pq
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/pq'
  CC       pq_query_helper.lo
  CC       pq_result_helper.lo
  CCLD     libtalerpq.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/pq'
Making all in sq
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/sq'
  CC       sq_query_helper.lo
  CC       sq_result_helper.lo
  CCLD     libtalersq.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/sq'
Making all in mhd
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/mhd'
  CC       mhd_config.lo
  CC       mhd_legal.lo
  CC       mhd_parsing.lo
  CC       mhd_responses.lo
  CCLD     libtalermhd.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/mhd'
Making all in bank-lib
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/bank-lib'
  CC       taler-wire-gateway-client.o
  CC       bank_api_admin.lo
  CC       bank_api_common.lo
  CC       bank_api_credit.lo
  CC       bank_api_debit.lo
  CC       bank_api_transfer.lo
  CC       bank_api_parse.lo
  CC       taler-fakebank-run.o
  CC       fakebank.lo
  CCLD     libtalerbank.la
  CCLD     taler-wire-gateway-client
  CCLD     libtalerfakebank.la
  CCLD     taler-fakebank-run
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/bank-lib'
Making all in exchangedb
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/exchangedb'
  CC       exchangedb_accounts.lo
  CC       exchangedb_plugin.lo
  CC       exchangedb_transactions.lo
  CC       plugin_exchangedb_postgres.lo
  CCLD     libtalerexchangedb.la
  CCLD     libtaler_plugin_exchangedb_postgres.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/exchangedb'
Making all in exchange
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/exchange'
  CC       taler-exchange-aggregator.o
  CCLD     taler-exchange-aggregator
  CC       taler-exchange-closer.o
  CCLD     taler-exchange-closer
  CC       taler-exchange-httpd.o
  CC       taler-exchange-httpd_auditors.o
  CC       taler-exchange-httpd_db.o
  CC       taler-exchange-httpd_deposit.o
  CC       taler-exchange-httpd_deposits_get.o
  CC       taler-exchange-httpd_keys.o
  CC       taler-exchange-httpd_link.o
  CC       taler-exchange-httpd_loop.o
  CC       taler-exchange-httpd_management_auditors.o
  CC       taler-exchange-httpd_management_auditors_AP_disable.o
  CC       taler-exchange-httpd_management_denominations_HDP_revoke.o
  CC       taler-exchange-httpd_management_post_keys.o
  CC       taler-exchange-httpd_management_signkey_EP_revoke.o
  CC       taler-exchange-httpd_management_wire.o
  CC       taler-exchange-httpd_management_wire_disable.o
  CC       taler-exchange-httpd_management_wire_fees.o
  CC       taler-exchange-httpd_melt.o
  CC       taler-exchange-httpd_mhd.o
  CC       taler-exchange-httpd_recoup.o
  CC       taler-exchange-httpd_refreshes_reveal.o
  CC       taler-exchange-httpd_refund.o
  CC       taler-exchange-httpd_reserves_get.o
  CC       taler-exchange-httpd_responses.o
  CC       taler-exchange-httpd_terms.o
  CC       taler-exchange-httpd_transfers_get.o
  CC       taler-exchange-httpd_wire.o
  CC       taler-exchange-httpd_withdraw.o
  CCLD     taler-exchange-httpd
  CC       taler-exchange-transfer.o
  CCLD     taler-exchange-transfer
  CC       taler-exchange-wirewatch.o
  CCLD     taler-exchange-wirewatch
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/exchange'
Making all in auditordb
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/auditordb'
  CC       auditordb_plugin.lo
  CC       plugin_auditordb_postgres.lo
  CCLD     libtalerauditordb.la
  CCLD     libtaler_plugin_auditordb_postgres.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/auditordb'
Making all in auditor
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/auditor'
  CC       taler_auditor_dbinit-taler-auditor-dbinit.o
  CCLD     taler-auditor-dbinit
  CC       taler-auditor-exchange.o
  CCLD     taler-auditor-exchange
  CC       taler-auditor-httpd.o
  CC       taler-auditor-httpd_deposit-confirmation.o
  CC       taler-auditor-httpd_exchanges.o
  CC       taler-auditor-httpd_mhd.o
  CCLD     taler-auditor-httpd
  CC       taler_auditor_sync-taler-auditor-sync.o
  CCLD     taler-auditor-sync
  CC       taler-helper-auditor-aggregation.o
  CC       report-lib.lo
  CCLD     libauditorreport.la
  CCLD     taler-helper-auditor-aggregation
  CC       taler-helper-auditor-coins.o
  CCLD     taler-helper-auditor-coins
  CC       taler-helper-auditor-deposits.o
  CCLD     taler-helper-auditor-deposits
  CC       taler-helper-auditor-reserves.o
  CCLD     taler-helper-auditor-reserves
  CC       taler-helper-auditor-wire.o
  CCLD     taler-helper-auditor-wire
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/auditor'
Making all in lib
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/lib'
  CC       auditor_api_curl_defaults.lo
  CC       auditor_api_handle.lo
  CC       auditor_api_deposit_confirmation.lo
  CC       auditor_api_exchanges.lo
  CC       exchange_api_auditor_add_denomination.lo
  CC       exchange_api_curl_defaults.lo
  CC       exchange_api_common.lo
  CC       exchange_api_handle.lo
  CC       exchange_api_deposit.lo
  CC       exchange_api_deposits_get.lo
  CC       exchange_api_link.lo
  CC       exchange_api_management_auditor_disable.lo
  CC       exchange_api_management_auditor_enable.lo
  CC       exchange_api_management_get_keys.lo
  CC       exchange_api_management_post_keys.lo
  CC       exchange_api_management_revoke_denomination_key.lo
  CC       exchange_api_management_revoke_signing_key.lo
  CC       exchange_api_management_set_wire_fee.lo
  CC       exchange_api_management_wire_disable.lo
  CC       exchange_api_management_wire_enable.lo
  CC       exchange_api_melt.lo
  CC       exchange_api_recoup.lo
  CC       exchange_api_refresh_common.lo
  CC       exchange_api_refreshes_reveal.lo
  CC       exchange_api_refund.lo
  CC       exchange_api_reserves_get.lo
  CC       exchange_api_transfers_get.lo
  CC       exchange_api_withdraw.lo
  CC       exchange_api_withdraw2.lo
  CC       exchange_api_wire.lo
  CCLD     libtalerauditor.la
  CCLD     libtalerexchange.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/lib'
Making all in exchange-tools
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/exchange-tools'
  CC       taler-auditor-offline.o
  CC       taler-exchange-offline.o
  CC       taler_exchange_dbinit-taler-exchange-dbinit.o
  CCLD     taler-exchange-dbinit
  CCLD     taler-auditor-offline
  CCLD     taler-exchange-offline
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/exchange-tools'
Making all in testing
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/testing'
  CC       testing_api_cmd_auditor_add_denom_sig.lo
  CC       testing_api_cmd_auditor_add.lo
  CC       testing_api_cmd_auditor_del.lo
  CC       testing_api_cmd_auditor_deposit_confirmation.lo
  CC       testing_api_cmd_auditor_exchanges.lo
  CC       testing_api_cmd_auditor_exec_auditor.lo
  CC       testing_api_cmd_auditor_exec_auditor_dbinit.lo
  CC       testing_api_cmd_bank_admin_add_incoming.lo
  CC       testing_api_cmd_bank_check.lo
  CC       testing_api_cmd_bank_admin_check.lo
  CC       testing_api_cmd_bank_check_empty.lo
  CC       testing_api_cmd_bank_history_credit.lo
  CC       testing_api_cmd_bank_history_debit.lo
  CC       testing_api_cmd_bank_transfer.lo
  CC       testing_api_cmd_batch.lo
  CC       testing_api_cmd_change_auth.lo
  CC       testing_api_cmd_check_keys.lo
  CC       testing_api_cmd_deposit.lo
  CC       testing_api_cmd_deposits_get.lo
  CC       testing_api_cmd_exec_aggregator.lo
  CC       testing_api_cmd_exec_closer.lo
  CC       testing_api_cmd_exec_transfer.lo
  CC       testing_api_cmd_exec_wirewatch.lo
  CC       testing_api_cmd_insert_deposit.lo
  CC       testing_api_cmd_offline_sign_fees.lo
  CC       testing_api_cmd_offline_sign_keys.lo
  CC       testing_api_cmd_set_wire_fee.lo
  CC       testing_api_cmd_recoup.lo
  CC       testing_api_cmd_refund.lo
  CC       testing_api_cmd_refresh.lo
  CC       testing_api_cmd_revoke.lo
  CC       testing_api_cmd_revoke_denom_key.lo
  CC       testing_api_cmd_revoke_sign_key.lo
  CC       testing_api_cmd_rewind.lo
  CC       testing_api_cmd_serialize_keys.lo
  CC       testing_api_cmd_signal.lo
  CC       testing_api_cmd_sleep.lo
  CC       testing_api_cmd_stat.lo
  CC       testing_api_cmd_status.lo
  CC       testing_api_cmd_transfer_get.lo
  CC       testing_api_cmd_wait.lo
  CC       testing_api_cmd_wire.lo
  CC       testing_api_cmd_wire_add.lo
  CC       testing_api_cmd_wire_del.lo
  CC       testing_api_cmd_withdraw.lo
  CC       testing_api_helpers_auditor.lo
  CC       testing_api_helpers_bank.lo
  CC       testing_api_helpers_exchange.lo
  CC       testing_api_loop.lo
  CC       testing_api_traits.lo
  CC       testing_api_trait_amount.lo
  CC       testing_api_trait_blinding_key.lo
  CC       testing_api_trait_cmd.lo
  CC       testing_api_trait_coin_priv.lo
  CC       testing_api_trait_contract.lo
  CC       testing_api_trait_denom_pub.lo
  CC       testing_api_trait_denom_sig.lo
  CC       testing_api_trait_exchange_pub.lo
  CC       testing_api_trait_exchange_sig.lo
  CC       testing_api_trait_fresh_coin.lo
  CC       testing_api_trait_json.lo
  CC       testing_api_trait_merchant_key.lo
  CC       testing_api_trait_number.lo
  CC       testing_api_trait_process.lo
  CC       testing_api_trait_reserve_history.lo
  CC       testing_api_trait_reserve_pub.lo
  CC       testing_api_trait_reserve_priv.lo
  CC       testing_api_trait_string.lo
  CC       testing_api_trait_time.lo
  CC       testing_api_trait_uuid.lo
  CC       testing_api_trait_wtid.lo
  CCLD     libtalertesting.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/testing'
Making all in benchmark
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/benchmark'
  CC       taler-bank-benchmark.o
  CC       taler-exchange-benchmark.o
  CCLD     taler-bank-benchmark
  CCLD     taler-exchange-benchmark
/usr/bin/ld: /home/ttn/t/lib/libtalerexchange.so.4: undefined reference to `TALER_amount_get_zero'
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:529: taler-bank-benchmark] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/benchmark'
make[2]: *** [Makefile:515: all-recursive] Error 1
make[2]: Leaving directory '/home/ttn/build/GNU/T/exchange/src'
make[1]: *** [Makefile:501: all-recursive] Error 1
make[1]: Leaving directory '/home/ttn/build/GNU/T/exchange'
make: *** [Makefile:433: all] Error 2

Compilation exited abnormally with code 2 at Fri Jul 23 13:29:39
.ttn.exchange-make.log (14,701 bytes)   

Christian Grothoff

2021-07-23 13:51

manager   ~0018007

Please try 'make install', we just renamed a symbol 5 seconds ago...

ttn

2021-07-24 01:11

developer   ~0018010

I'm re-opening this due to a small confusion i have:

Hmm, are you sure doing "make install" the right step to take?
The failiure is in "make" (NOT "make check"), which logically occurs BEFORE "make install".
IME, the usual Automake-generated makefiles would require "make" to succeed
prior to "make install", anyway. I am loathe to even try it because if "make install"
DOES succeed in clearing up the problem, it might then mask an indeterminism
in the build process that will come back to bite us later.

Christian Grothoff

2021-07-24 10:16

manager   ~0018014

This only is relevant to devs. you could also run 'make uninstall' to fix it. Please, this is not a build system issue.

Issue History

Date Modified Username Field Change
2021-07-23 13:39 ttn New Issue
2021-07-23 13:39 ttn Status new => assigned
2021-07-23 13:39 ttn Assigned To => Christian Grothoff
2021-07-23 13:39 ttn File Added: .ttn.exchange-make.log
2021-07-23 13:51 Christian Grothoff Note Added: 0018007
2021-07-23 13:51 Christian Grothoff Status assigned => resolved
2021-07-23 13:51 Christian Grothoff Resolution open => fixed
2021-07-23 13:51 Christian Grothoff Fixed in Version => 0.9
2021-07-24 01:11 ttn Status resolved => feedback
2021-07-24 01:11 ttn Resolution fixed => reopened
2021-07-24 01:11 ttn Note Added: 0018010
2021-07-24 10:16 Christian Grothoff Note Added: 0018014
2021-07-24 10:16 Christian Grothoff Status feedback => resolved
2021-07-24 10:16 Christian Grothoff Resolution reopened => no change required
2021-07-24 10:16 Christian Grothoff Target Version => 0.9
2021-07-30 13:57 Christian Grothoff Fixed in Version 0.9 => 0.8.1
2021-07-30 13:59 Christian Grothoff Target Version 0.9 => 0.8.1
2021-07-30 14:01 Christian Grothoff Fixed in Version 0.8.1 => 0.8
2021-07-30 14:02 Christian Grothoff Target Version 0.8.1 => 0.8
2021-08-24 16:22 Christian Grothoff Status resolved => closed