View Issue Details

IDProjectCategoryView StatusLast Update
0006916GNUnetcore servicepublic2021-07-24 10:58
Reporterbaseball11 Assigned Tothejackimonster  
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionopen 
Product VersionGit master 
Target Version0.15.0Fixed in VersionGit master 
Summary0006916: Unabled to use GNUNet Library with C++.
Descriptionstruct GNUNET_MESSENGER_MessageBody
(In file: src/include/gnunet_messenger_service.h)
's member variables using C++ reserved words(delete and private)

Because of this It's impossible to use gnunet library with C++ (Cause compile error).

I tried to commit, but I don't seem to have an access to the repository, so I post this here.

Thank you.

TagsNo tags attached.

Activities

thejackimonster

2021-07-17 21:14

developer   ~0017994

This should be fixed now with following commit:
https://git.gnunet.org/gnunet.git/commit/?id=c892ac24758e34a109db15df17fdf38e27ac7de3

Issue History

Date Modified Username Field Change
2021-07-09 14:40 baseball11 New Issue
2021-07-17 20:21 Christian Grothoff Assigned To => thejackimonster
2021-07-17 20:21 Christian Grothoff Status new => assigned
2021-07-17 21:14 thejackimonster Note Added: 0017994
2021-07-22 11:19 schanzen Status assigned => resolved
2021-07-22 11:19 schanzen Fixed in Version => Git master
2021-07-22 11:19 schanzen Target Version => 0.16.0
2021-07-24 10:58 schanzen Target Version 0.16.0 => 0.15.0