View Issue Details

IDProjectCategoryView StatusLast Update
0006862Talerexchangepublic2021-05-15 11:31
Reporterttn Assigned Tottn  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSAlpineOS Version3.13
Product Versiongit (master) 
Summary0006862: "make" fails
DescriptionHEAD at 5f268913ddfac25f8d16c3216bba23535e2bd798
log attached

This is after (proper) installation of GNU gettext 0.19.8, as required by the configure script.
TagsNo tags attached.

Activities

ttn

2021-05-14 13:45

developer  

.ttn.make.log (4,112 bytes)   
make  all-recursive
make[1]: Entering directory '/home/ttn/build/GNU/T/exchange'
Making all in .
make[2]: Entering directory '/home/ttn/build/GNU/T/exchange'
make[2]: Leaving directory '/home/ttn/build/GNU/T/exchange'
Making all in contrib
make[2]: Entering directory '/home/ttn/build/GNU/T/exchange/contrib'
Making all in .
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/contrib'
make[3]: Nothing to be done for 'all-am'.
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/contrib'
make[2]: Leaving directory '/home/ttn/build/GNU/T/exchange/contrib'
Making all in src
make[2]: Entering directory '/home/ttn/build/GNU/T/exchange/src'
Making all in include
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/include'
make[3]: Nothing to be done for 'all'.
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/include'
Making all in util
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/util'
  CC       taler-exchange-secmod-eddsa.o
  CC       amount.lo
  CC       auditor_signatures.lo
  CC       config.lo
  CC       crypto.lo
  CC       crypto_helper_denom.lo
crypto_helper_denom.c: In function 'TALER_CRYPTO_helper_denom_sign':
crypto_helper_denom.c:538:19: warning: passing argument 5 of 'sendto' from incompatible pointer type [-Wincompatible-pointer-types]
  538 |                   &dh->sa,
      |                   ^~~~~~~
      |                   |
      |                   struct sockaddr_un *
In file included from /usr/include/netinet/in.h:10,
                 from /usr/include/netdb.h:9,
                 from /usr/local/include/gnunet/platform.h:72,
                 from ../../src/include/platform.h:46,
                 from crypto_helper_denom.c:21:
/usr/include/fortify/sys/socket.h:65:59: note: expected 'const struct sockaddr *' but argument is of type 'struct sockaddr_un *'
   65 |                                    const struct sockaddr *__a, socklen_t __l)
      |                                    ~~~~~~~~~~~~~~~~~~~~~~~^~~
  CC       crypto_helper_esign.lo
crypto_helper_esign.c: In function 'TALER_CRYPTO_helper_esign_sign_':
crypto_helper_esign.c:488:19: warning: passing argument 5 of 'sendto' from incompatible pointer type [-Wincompatible-pointer-types]
  488 |                   &esh->sa,
      |                   ^~~~~~~~
      |                   |
      |                   struct sockaddr_un *
In file included from /usr/include/netinet/in.h:10,
                 from /usr/include/netdb.h:9,
                 from /usr/local/include/gnunet/platform.h:72,
                 from ../../src/include/platform.h:46,
                 from crypto_helper_esign.c:21:
/usr/include/fortify/sys/socket.h:65:59: note: expected 'const struct sockaddr *' but argument is of type 'struct sockaddr_un *'
   65 |                                    const struct sockaddr *__a, socklen_t __l)
      |                                    ~~~~~~~~~~~~~~~~~~~~~~~^~~
  CC       crypto_wire.lo
  CC       getopt.lo
  CC       lang.lo
  CC       mhd.lo
  CC       offline_signatures.lo
  CC       payto.lo
  CC       secmod_signatures.lo
  CC       taler_error_codes.lo
  CC       url.lo
  CC       util.lo
  CC       wallet_signatures.lo
  CC       yna.lo
  CC       os_installation.lo
  CCLD     libtalerutil.la
  CCLD     taler-exchange-secmod-eddsa
/usr/lib/gcc/x86_64-alpine-linux-musl/10.2.1/../../../../x86_64-alpine-linux-musl/bin/ld: taler-exchange-secmod-eddsa.o: undefined reference to symbol 'libintl_dgettext'
/usr/lib/gcc/x86_64-alpine-linux-musl/10.2.1/../../../../x86_64-alpine-linux-musl/bin/ld: /usr/local/lib/libintl.so.8: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:917: taler-exchange-secmod-eddsa] Error 1
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/util'
make[2]: *** [Makefile:515: all-recursive] Error 1
make[2]: Leaving directory '/home/ttn/build/GNU/T/exchange/src'
make[1]: *** [Makefile:501: all-recursive] Error 1
make[1]: Leaving directory '/home/ttn/build/GNU/T/exchange'
make: *** [Makefile:433: all] Error 2
.ttn.make.log (4,112 bytes)   

Christian Grothoff

2021-05-14 15:49

manager   ~0017849

Can you please try with 5f268913..ab96483e? I've removed the gettext logic from the security module helpers in that commit.

ttn

2021-05-14 16:21

developer   ~0017851

Unfortunately, that doesn't seem to help. In the attached log, the erorr message looks like the one in the previous log (no change).
.ttn.make-2.log (4,314 bytes)   
make  all-recursive
make[1]: Entering directory '/home/ttn/build/GNU/T/exchange'
Making all in .
make[2]: Entering directory '/home/ttn/build/GNU/T/exchange'
make[2]: Nothing to be done for 'all-am'.
make[2]: Leaving directory '/home/ttn/build/GNU/T/exchange'
Making all in contrib
make[2]: Entering directory '/home/ttn/build/GNU/T/exchange/contrib'
Making all in .
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/contrib'
make[3]: Nothing to be done for 'all-am'.
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/contrib'
make[2]: Leaving directory '/home/ttn/build/GNU/T/exchange/contrib'
Making all in src
make[2]: Entering directory '/home/ttn/build/GNU/T/exchange/src'
Making all in include
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/include'
make[3]: Nothing to be done for 'all'.
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/include'
Making all in util
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/util'
  CC       taler-exchange-secmod-eddsa.o
  CC       amount.lo
  CC       auditor_signatures.lo
  CC       config.lo
  CC       crypto.lo
  CC       crypto_helper_denom.lo
  CC       crypto_helper_esign.lo
  CC       crypto_wire.lo
  CC       getopt.lo
  CC       lang.lo
  CC       mhd.lo
  CC       offline_signatures.lo
  CC       payto.lo
  CC       secmod_signatures.lo
  CC       taler_error_codes.lo
  CC       url.lo
  CC       util.lo
  CC       wallet_signatures.lo
  CC       yna.lo
  CC       os_installation.lo
  CCLD     libtalerutil.la
  CCLD     taler-exchange-secmod-eddsa
  CC       taler-exchange-secmod-rsa.o
  CCLD     taler-exchange-secmod-rsa
rm -f taler-config taler-config.tmp && \
/bin/sed -e 's,%libdir%,/usr/local/lib,'g  taler-config.in >taler-config.tmp && \
chmod a-w+x taler-config.tmp && \
mv taler-config.tmp taler-config
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/util'
Making all in json
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/json'
  CC       i18n.lo
  CC       json.lo
  CC       json_helper.lo
  CC       json_wire.lo
  CCLD     libtalerjson.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/json'
Making all in curl
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/curl'
  CC       curl.lo
  CCLD     libtalercurl.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/curl'
Making all in pq
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/pq'
  CC       pq_query_helper.lo
  CC       pq_result_helper.lo
  CCLD     libtalerpq.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/pq'
Making all in sq
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/sq'
  CC       sq_query_helper.lo
  CC       sq_result_helper.lo
  CCLD     libtalersq.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/sq'
Making all in mhd
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/mhd'
  CC       mhd_config.lo
  CC       mhd_legal.lo
  CC       mhd_parsing.lo
  CC       mhd_responses.lo
  CCLD     libtalermhd.la
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/mhd'
Making all in bank-lib
make[3]: Entering directory '/home/ttn/build/GNU/T/exchange/src/bank-lib'
  CC       taler-wire-gateway-client.o
  CC       bank_api_admin.lo
  CC       bank_api_common.lo
  CC       bank_api_credit.lo
  CC       bank_api_debit.lo
  CC       bank_api_transfer.lo
  CC       bank_api_parse.lo
  CCLD     libtalerbank.la
  CCLD     taler-wire-gateway-client
/usr/lib/gcc/x86_64-alpine-linux-musl/10.2.1/../../../../x86_64-alpine-linux-musl/bin/ld: taler-wire-gateway-client.o: undefined reference to symbol 'libintl_dgettext'
/usr/lib/gcc/x86_64-alpine-linux-musl/10.2.1/../../../../x86_64-alpine-linux-musl/bin/ld: /usr/local/lib/libintl.so.8: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:662: taler-wire-gateway-client] Error 1
make[3]: Leaving directory '/home/ttn/build/GNU/T/exchange/src/bank-lib'
make[2]: *** [Makefile:515: all-recursive] Error 1
make[2]: Leaving directory '/home/ttn/build/GNU/T/exchange/src'
make[1]: *** [Makefile:501: all-recursive] Error 1
make[1]: Leaving directory '/home/ttn/build/GNU/T/exchange'
make: *** [Makefile:433: all] Error 2
.ttn.make-2.log (4,314 bytes)   

Christian Grothoff

2021-05-14 18:11

manager   ~0017852

Similar error, different location. Please try with ab96483e..3ef39e51.

ttn

2021-05-15 11:31

developer   ~0017853

That did the trick! Both "make" and "make check" finish successfullly now.

Issue History

Date Modified Username Field Change
2021-05-14 13:45 ttn New Issue
2021-05-14 13:45 ttn Status new => assigned
2021-05-14 13:45 ttn Assigned To => Christian Grothoff
2021-05-14 13:45 ttn File Added: .ttn.make.log
2021-05-14 15:49 Christian Grothoff Note Added: 0017849
2021-05-14 15:49 Christian Grothoff Assigned To Christian Grothoff => ttn
2021-05-14 15:49 Christian Grothoff Status assigned => feedback
2021-05-14 16:21 ttn Note Added: 0017851
2021-05-14 16:21 ttn File Added: .ttn.make-2.log
2021-05-14 18:11 Christian Grothoff Note Added: 0017852
2021-05-15 11:31 ttn Note Added: 0017853
2021-05-15 11:31 ttn Status feedback => resolved
2021-05-15 11:31 ttn Resolution open => fixed