View Issue Details

IDProjectCategoryView StatusLast Update
0006839Talerexchangepublic2021-08-24 16:23
Reportersebasjm Assigned Tosebasjm  
Status closedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006839: cannot build exchange
DescriptionIm trying to build anastasis, for that I was working in the build process of the exchange but failed when running make

taler_error_codes.c:26:10: fatal error: gettext.h: No such file or directory
   26 | #include <gettext.h>

I saw that gana was updated here

gettext is installed and gettext.h is in the filesystem
But found strange that ./configure didnt check for this.

I can work around meanwhile

export CFLAGS="-I/usr/share/gettext"
Additional Information#cat /etc/issue
Debian GNU/Linux bullseye/sid
TagsNo tags attached.


Christian Grothoff

2021-04-08 23:59

manager   ~0017714

We don't check for it because gettext.h should be in exchange.git/src/include/gettext.h -- so the system version should NOT be needed. But maybe the INCLUDE path in the Makefile is wrong? Let me investigate.

Christian Grothoff

2021-04-09 00:02

manager   ~0017715

I just removed my system's gettext, and the build worked fine. Do you really have the latest Git with src/include/gettext.h present?


2021-04-09 00:23

developer   ~0017716

I didnt have the latest version of the exchange.
Now I have the gettext.h in the repository so I expect this to work without the workaround as you mention.

But, an older version of the exchange is not going to build with this gana version and the exchange is always going to download the latest gana from git?


2021-04-09 00:32

developer   ~0017717

Yes, build process worked as expected.

Maybe the script should not pull the latest version from master but to use the version referenced by the commit submodule.
If the exchange needs a newer version it can push a different "Subproject commit" after the gana repository was updated.

Christian Grothoff

2021-04-09 16:36

manager   ~0017721

I am not sure how the version pulled by the script relates to anything here. Anyway, what I do think is that
the bootstrap script should not update Gana to master, that should be done by a manual invocation of contrib/

So I have changed this so that bootstrap only updates the submodules, and updating to the latest gana requires manually calling

Christian Grothoff

2021-04-09 16:38

manager   ~0017722

All good now?


2021-04-09 16:54

developer   ~0017724

sed 's/' -i last_comment

> So I have changed this so that bootstrap only updates the submodules, and updating to the latest gana requires manually calling
Yes, this is what I meant. Bootstrap should not pull remote master

> All good now?
Yes, thanks

Issue History

Date Modified Username Field Change
2021-04-08 21:17 sebasjm New Issue
2021-04-08 21:17 sebasjm Status new => assigned
2021-04-08 21:17 sebasjm Assigned To => Christian Grothoff
2021-04-08 23:59 Christian Grothoff Note Added: 0017714
2021-04-09 00:02 Christian Grothoff Note Added: 0017715
2021-04-09 00:02 Christian Grothoff Status assigned => feedback
2021-04-09 00:02 Christian Grothoff Target Version git (master) => 0.9
2021-04-09 00:23 sebasjm Note Added: 0017716
2021-04-09 00:23 sebasjm Status feedback => assigned
2021-04-09 00:32 sebasjm Note Added: 0017717
2021-04-09 16:36 Christian Grothoff Note Added: 0017721
2021-04-09 16:38 Christian Grothoff Assigned To Christian Grothoff => sebasjm
2021-04-09 16:38 Christian Grothoff Status assigned => feedback
2021-04-09 16:38 Christian Grothoff Note Added: 0017722
2021-04-09 16:54 sebasjm Note Added: 0017724
2021-04-09 16:55 sebasjm Status feedback => resolved
2021-04-09 16:55 sebasjm Resolution open => fixed
2021-07-30 13:56 Christian Grothoff Fixed in Version => 0.8
2021-07-30 13:59 Christian Grothoff Target Version 0.9 => 0.8.1
2021-07-30 14:02 Christian Grothoff Target Version 0.8.1 => 0.8
2021-08-24 16:23 Christian Grothoff Status resolved => closed