View Issue Details

IDProjectCategoryView StatusLast Update
0006822Talermechant backendpublic2021-09-02 18:23
Reportersebasjm Assigned ToChristian Grothoff  
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006822: more info of an unpaid order
DescriptionIm working in the details of order, looking into the documentation seems like when making a request into an unpaid order doesnt bring some basic information.

How easy is to add 3 fields that we have in the OrderHistory?

      // When the order was created.
      timestamp: Timestamp;
      // The amount of money the order is for.
      amount: Amount;
      // The summary of the order.
      summary: string;



Here is the response:
https://docs.taler.net/core/api-merchant.html#tsref-type-CheckPaymentUnpaidResponse

    interface CheckPaymentUnpaidResponse {
      // The order was neither claimed nor paid.
      order_status: "unpaid";

      // URI that the wallet must process to complete the payment.
      taler_pay_uri: string;

      // Alternative order ID which was paid for already in the same session.
      // Only given if the same product was purchased before in the same session.
      already_paid_order_id?: string;

      // Fulfillment URL of an already paid order. Only given if under this
      // session an already paid order with a fulfillment URL exists.
      already_paid_fulfillment_url?: string;

      // Status URL, can be used as a redirect target for the browser
      // to show the order QR code / trigger the wallet.
      order_status_url: string;

      // We do we NOT return the contract terms here because they may not
      // exist in case the wallet did not yet claim them.
    }
TagsNo tags attached.

Activities

Christian Grothoff

2021-03-30 23:32

manager   ~0017659

Sounds reasonable, should not be too hard to return. I will add this.

Christian Grothoff

2021-04-01 11:19

manager   ~0017666

API specification updated in 44cbd51..ae616b4

Christian Grothoff

2021-04-01 11:20

manager   ~0017667

Implemented in 3694bff..cc802c0.

Christian Grothoff

2021-09-02 18:23

manager   ~0018355

Fix committed to master branch.

Related Changesets

merchant: master cc802c04

2021-04-01 11:18:34

Christian Grothoff

Details Diff
implement returning additional order details for unpaid orders (fixes 0006822) Affected Issues
0006822
mod - src/backend/taler-merchant-httpd_private-get-orders-ID.c Diff File
mod - src/include/taler_merchant_service.h Diff File
mod - src/lib/merchant_api_merchant_get_order.c Diff File

Issue History

Date Modified Username Field Change
2021-03-29 19:11 sebasjm New Issue
2021-03-29 19:11 sebasjm Status new => assigned
2021-03-29 19:11 sebasjm Assigned To => Christian Grothoff
2021-03-30 23:32 Christian Grothoff Note Added: 0017659
2021-03-30 23:32 Christian Grothoff Priority normal => high
2021-03-30 23:32 Christian Grothoff Target Version git (master) => 0.9
2021-04-01 11:19 Christian Grothoff Note Added: 0017666
2021-04-01 11:20 Christian Grothoff Note Added: 0017667
2021-04-01 11:20 Christian Grothoff Status assigned => resolved
2021-04-01 11:20 Christian Grothoff Resolution open => fixed
2021-04-01 11:20 Christian Grothoff Fixed in Version => 0.9
2021-07-30 13:57 Christian Grothoff Fixed in Version 0.9 => 0.8.1
2021-07-30 13:59 Christian Grothoff Target Version 0.9 => 0.8.1
2021-07-30 14:01 Christian Grothoff Fixed in Version 0.8.1 => 0.8
2021-07-30 14:02 Christian Grothoff Target Version 0.8.1 => 0.8
2021-08-24 16:23 Christian Grothoff Status resolved => closed
2021-09-02 18:22 Christian Grothoff Changeset attached => Taler-merchant master cc802c04
2021-09-02 18:23 Christian Grothoff Note Added: 0018355