View Issue Details

IDProjectCategoryView StatusLast Update
0006818GNUnetutil librarypublic2021-05-10 21:59
Reporterschanzen Assigned ToChristian Grothoff  
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.14.2Fixed in Version0.15.0 
Summary0006818: Util ECC dlog tests fail
DescriptionRunning the test yields:
.Ohhhh jeeee: mulm_25519: different sizes
Followed by a SIGABRT.

Stacktrace:

    frame #3: 0x0000000100426491 libgcrypt.20.dylib`_gcry_logv.cold.1 + 48
    frame #4: 0x00000001003b9361 libgcrypt.20.dylib`_gcry_logv + 215
    frame #5: 0x00000001003b9692 libgcrypt.20.dylib`_gcry_log_bug + 122
    frame #6: 0x0000000100425d8d libgcrypt.20.dylib`ec_mulm_25519 + 502
    frame #7: 0x00000001004244f8 libgcrypt.20.dylib`add_points_edwards + 53
    frame #8: 0x00000001001313a6 libgnunetutil.14.dylib`GNUNET_CRYPTO_ecc_dlog(edc=0x0000000100704420, input=0x00000001018049b0) at crypto_ecc_dlog.c:0 [opt]
    frame #9: 0x00000001000038f1 test_crypto_ecc_dlog`main [inlined] test_dlog(edc=0x0000000100704420) at test_crypto_ecc_dlog.c:101:17 [opt]
    frame #10: 0x0000000100003812 test_crypto_ecc_dlog`main(argc=<unavailable>, argv=<unavailable>) at test_crypto_ecc_dlog.c:188 [opt]
    frame #11: 0x00007fff6d3c5cc9 libdyld.dylib`start + 1

This may be a regression. Did not investigate further.
TagsNo tags attached.

Activities

Christian Grothoff

2021-03-28 19:08

manager   ~0017653

I cannot reproduce this with libgcrypt 1.8.7-3 from Debian. Which version are you using? Does it happen every time?

schanzen

2021-03-28 19:30

manager   ~0017654

I used 1.9.2. Yes, it does happen everytime. It is this error: http://gnupg.10057.n7.nabble.com/Ohhhh-jeeee-mulm-25519-different-sizes-td56665.html

schanzen

2021-03-29 09:37

manager   ~0017655

This seems to be an issue with 1.9.X. Independently verified by t3ss (1.8.2) and ch3 (1.9.2)

Christian Grothoff

2021-03-29 13:26

manager   ~0017656

Previously reported here: https://lists.gnupg.org/pipermail/gcrypt-devel/2018-August/004534.html

schanzen

2021-03-31 13:51

manager   ~0017661

I disabled the build and test for crypto_ecc_dlog as well as the whole scalarproduct subsystem if we detect libgcrypt 1.9.
Note that this "kind of" puts scalarproduct on a depecation timer as eventually systems will no longer ship 1.8. Keeping this bug open. Target version 0.15.0 due to likely breakage of API on fix.

A libsodium implementation for ecc_dlog is in https://git.gnunet.org/gnunet.git/log/?h=dev/schanzen/crypto_dlog_sodium

Christian Grothoff

2021-04-18 16:32

manager   ~0017763

I have now gotten the util ECC dlog tests to pass and the scalarproduct code to compile.
However, the scalarproduct test still fails. Likely somewhere I am not correctly understanding/using some libsodium operation, OR (less likely) there was a "simple" bug in translation of the code :-(.

Anyway, the next thing to fix is definitively test_ecc_scalarproduct, and once that passes, we should be able to get the rest to pass by apply the same fix to the Alice/Bob logic.

Christian Grothoff

2021-04-18 18:44

manager   ~0017764

Code now works in the branch, ready to merge.

Christian Grothoff

2021-04-18 21:15

manager   ~0017765

Fixed in 5ec7af75e..f022b206a

Issue History

Date Modified Username Field Change
2021-03-28 12:32 schanzen New Issue
2021-03-28 12:32 schanzen Status new => assigned
2021-03-28 12:32 schanzen Assigned To => Christian Grothoff
2021-03-28 19:08 Christian Grothoff Note Added: 0017653
2021-03-28 19:30 schanzen Note Added: 0017654
2021-03-29 09:37 schanzen Note Added: 0017655
2021-03-29 13:26 Christian Grothoff Note Added: 0017656
2021-03-31 13:51 schanzen Target Version 0.14.1 => 0.15.0
2021-03-31 13:51 schanzen Note Added: 0017661
2021-04-18 16:32 Christian Grothoff Note Added: 0017763
2021-04-18 18:44 Christian Grothoff Note Added: 0017764
2021-04-18 21:15 Christian Grothoff Status assigned => resolved
2021-04-18 21:15 Christian Grothoff Resolution open => fixed
2021-04-18 21:15 Christian Grothoff Fixed in Version => 0.15.0
2021-04-18 21:15 Christian Grothoff Note Added: 0017765
2021-05-10 21:59 schanzen Target Version 0.15.0 => 0.14.2