View Issue Details

IDProjectCategoryView StatusLast Update
0006806Talerbank (demonstrator)public2021-08-24 16:23
ReporterStefan Assigned ToFlorian Dold  
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006806: test sites of Taler demonstration pages returns a 'Bad gateway' error
DescriptionHi,

The demonstration pages (https://demo.taler.net with bank, shop, donations, survey) have been translated to German, Italian, Spanish, Korean, Swedish and Portuguese. The language switch on the live web sites shows only English, German, Italian, Spanish, Swedish and Portuguese, but several other languages are on the way being finished soon.

So I tried to furnish at least the test pages of the Taler demo pages with 14 languages and extended the language-switcher.html.j2 file in /taler-merchant-demos/talermerchantdemos/templates/.

This worked for a while, but then a '502 Bad gateway' message appeared from nginx. I also eliminated some diacritics (ê, ñ...), but that does not help either. Could you be so kind to solve this issue? Thanks in advance!
Stefan
TagsNo tags attached.

Activities

Florian Dold

2021-03-15 12:19

manager   ~0017624

This seems to be some other issue with the test builder (https://buildbot.taler.net/#/builders/4/builds/2949) and unrelated to translations.

Will look into it!

Florian Dold

2021-04-14 14:10

manager   ~0017742

Fixed, but see 0006846 for some security-related tweaks.

Issue History

Date Modified Username Field Change
2021-03-14 12:19 Stefan New Issue
2021-03-14 12:19 Stefan Status new => assigned
2021-03-14 12:19 Stefan Assigned To => Florian Dold
2021-03-14 12:19 Stefan Tag Attached: test.taler.net
2021-03-14 20:09 Stefan Tag Detached: test.taler.net
2021-03-15 12:19 Florian Dold Note Added: 0017624
2021-04-14 14:10 Florian Dold Status assigned => resolved
2021-04-14 14:10 Florian Dold Resolution open => fixed
2021-04-14 14:10 Florian Dold Note Added: 0017742
2021-07-30 13:56 Christian Grothoff Fixed in Version => 0.8
2021-07-30 13:59 Christian Grothoff Target Version git (master) => 0.8.1
2021-07-30 14:01 Christian Grothoff Target Version 0.8.1 => 0.8
2021-08-24 16:23 Christian Grothoff Status resolved => closed