View Issue Details

IDProjectCategoryView StatusLast Update
0006774Talermerchant backend API (C)public2022-07-03 13:59
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Versiongit (master) 
Target Version0.9Fixed in Version0.9 
Summary0006774: ERROR BUG: Preflight check committed transaction `pickup tip'!
DescriptionFrom the "hacker news DoS" day:

Feb 26 13:44:47-285530 taler-merchant-httpd-3049906(K371ZSR3VZ5390MTJWHMR0TJHM) ERROR BUG: Preflight check committed transaction `pickup tip'!
TagsNo tags attached.

Activities

Christian Grothoff

2021-03-04 11:12

manager   ~0017591

I have combed over the transaction code three times now, cannot find any path where it is not orderly aborted or committed.WTF?

Christian Grothoff

2021-03-04 11:13

manager   ~0017592

We need to find a way to reproduce this.

Christian Grothoff

2022-07-03 13:59

manager   ~0018954

Looked again, best explanation is that it was fixed in the meantime. More checks added too now, but again nothing. Resolving as "unable to reproduce".

Issue History

Date Modified Username Field Change
2021-03-01 13:09 Florian Dold New Issue
2021-03-01 13:09 Florian Dold Status new => assigned
2021-03-01 13:09 Florian Dold Assigned To => Christian Grothoff
2021-03-04 11:12 Christian Grothoff Note Added: 0017591
2021-03-04 11:13 Christian Grothoff Assigned To Christian Grothoff =>
2021-03-04 11:13 Christian Grothoff Status assigned => feedback
2021-03-04 11:13 Christian Grothoff Note Added: 0017592
2021-03-04 11:21 Christian Grothoff Product Version => 0.8.1
2022-07-03 13:59 Christian Grothoff Assigned To => Christian Grothoff
2022-07-03 13:59 Christian Grothoff Status feedback => resolved
2022-07-03 13:59 Christian Grothoff Resolution open => unable to reproduce
2022-07-03 13:59 Christian Grothoff Fixed in Version => 0.9
2022-07-03 13:59 Christian Grothoff Note Added: 0018954
2022-07-03 13:59 Christian Grothoff Product Version => git (master)
2022-07-03 13:59 Christian Grothoff Target Version => 0.9