View Issue Details

IDProjectCategoryView StatusLast Update
0006735Talermechant backendpublic2021-08-24 16:23
Reporterttn Assigned ToChristian Grothoff  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformLinuxOSDevuanOS VersionBeowulf/Chimaera
Product Versiongit (master) 
Target Version0.8Fixed in Version0.8 
Summary0006735: "make" fails -- undeclared identifier TALER_EC_MERCHANT_GENERIC_UNAUTHORIZED
DescriptionFrom fresh "git pull" (HEAD == 25c0b949ab5a77cc6aafc442cecbcaca0c49b3f1).
TagsNo tags attached.

Activities

ttn

2021-02-01 18:50

developer  

.ttn.merchant-make.log (2,751 bytes)   
-*- mode: compilation; default-directory: "~/build/GNU/T/merchant/" -*-
Compilation started at Mon Feb  1 12:42:03

make -j2
make  all-recursive
make[1]: ingresso nella directory «/home/ttn/build/GNU/T/merchant»
Making all in .
make[2]: ingresso nella directory «/home/ttn/build/GNU/T/merchant»
make[2]: uscita dalla directory «/home/ttn/build/GNU/T/merchant»
Making all in src
make[2]: ingresso nella directory «/home/ttn/build/GNU/T/merchant/src»
Making all in include
make[3]: ingresso nella directory «/home/ttn/build/GNU/T/merchant/src/include»
make[3]: Nessuna operazione da eseguire per «all».
make[3]: uscita dalla directory «/home/ttn/build/GNU/T/merchant/src/include»
Making all in mustach
make[3]: ingresso nella directory «/home/ttn/build/GNU/T/merchant/src/mustach»
  CC       mustach-jansson.o
  AR       libmustach.a
ar: `u' modifier ignored since `D' is the default (see `U')
make[3]: uscita dalla directory «/home/ttn/build/GNU/T/merchant/src/mustach»
Making all in backenddb
make[3]: ingresso nella directory «/home/ttn/build/GNU/T/merchant/src/backenddb»
  CC       merchantdb_plugin.lo
  CC       plugin_merchantdb_postgres.lo
  CCLD     libtalermerchantdb.la
  CCLD     libtaler_plugin_merchantdb_postgres.la
make[3]: uscita dalla directory «/home/ttn/build/GNU/T/merchant/src/backenddb»
Making all in backend
make[3]: ingresso nella directory «/home/ttn/build/GNU/T/merchant/src/backend»
  CC       taler_merchant_httpd-taler-merchant-httpd.o
  CC       taler_merchant_httpd-taler-merchant-httpd_auditors.o
taler-merchant-httpd.c: In function ‘url_handler’:
taler-merchant-httpd.c:1546:44: error: ‘TALER_EC_MERCHANT_GENERIC_UNAUTHORIZED’ undeclared (first use in this function); did you mean ‘TALER_EC_MERCHANT_GENERIC_EXCHANGE_TIMEOUT’?
 1546 |                                            TALER_EC_MERCHANT_GENERIC_UNAUTHORIZED,
      |                                            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      |                                            TALER_EC_MERCHANT_GENERIC_EXCHANGE_TIMEOUT
taler-merchant-httpd.c:1546:44: note: each undeclared identifier is reported only once for each function it appears in
make[3]: *** [Makefile:759: taler_merchant_httpd-taler-merchant-httpd.o] Errore 1
make[3]: *** Attesa per i processi non terminati....
make[3]: uscita dalla directory «/home/ttn/build/GNU/T/merchant/src/backend»
make[2]: *** [Makefile:410: all-recursive] Errore 1
make[2]: uscita dalla directory «/home/ttn/build/GNU/T/merchant/src»
make[1]: *** [Makefile:471: all-recursive] Errore 1
make[1]: uscita dalla directory «/home/ttn/build/GNU/T/merchant»
make: *** [Makefile:403: all] Errore 2

Compilation exited abnormally with code 2 at Mon Feb  1 12:42:06
.ttn.merchant-make.log (2,751 bytes)   

Christian Grothoff

2021-02-01 19:00

manager   ~0017484

You need to re-build the exchange, starting with git pull, before building the merchant.

ttn

2021-02-01 20:24

developer   ~0017485

OK. Looks good now (both exchange and merchant built fine and pass "make check").
Sorry for the noise!

Issue History

Date Modified Username Field Change
2021-02-01 18:50 ttn New Issue
2021-02-01 18:50 ttn Status new => assigned
2021-02-01 18:50 ttn Assigned To => Christian Grothoff
2021-02-01 18:50 ttn File Added: .ttn.merchant-make.log
2021-02-01 19:00 Christian Grothoff Note Added: 0017484
2021-02-01 20:24 ttn Note Added: 0017485
2021-02-01 20:24 ttn Status assigned => resolved
2021-02-01 20:24 ttn Resolution open => fixed
2021-07-30 13:56 Christian Grothoff Fixed in Version => 0.8
2021-07-30 13:59 Christian Grothoff Target Version => 0.8.1
2021-07-30 14:01 Christian Grothoff Target Version 0.8.1 => 0.8
2021-08-24 16:23 Christian Grothoff Status resolved => closed